Peugeot Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Hi All
my daughter has a 2012 308 auto, the other day the pop up display came up but had a blank screen and the mileage indicator between the dials had changed to Km instead of miles and non of the radio buttons work,.
she has had a diagnostic test but no fault codes came up.
Has anyone any knowledge/experience of this fault.
thanks
Malc
 

·
Registered
Joined
·
1,290 Posts
it sounds similar to what happened with mine end of last year, which was it lost its configuration.

was it Peugeot diagnostics that were on the car?
 

·
Registered
Joined
·
7 Posts
Discussion Starter #5
Hi
Sorry my daughter is at work at the moment, I will find out when she returns, what did you have to do to yours to get it working again?
thanks
Malc
 

·
Registered
Joined
·
1,290 Posts
had to reconfigure some settings on mine via Planet/Diagbox which are Peugeot diagnostic tools.

main one that was wrong was in the Multi Function Display ECU, Vehicle Config the Connection tyoe to separate control was at NULL when should been VIA CAN network with RD4 radio (well for my car anyway).

once that was sorted, I could control the display again from the radio and the speedo milage back to miles instead of kph via the Customer Config in the MFD ECU.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #8
Radio seems to be the problem

Hi my daughter has since had the problem looked at by various auto electricians and specialist, no fault codes show and it appears that it is the radio that is the problem, it cannot be switched off and keeps trying to eject a cd, although there isn't a cd in the machine. A Peugeot technician has suggested it may need a software update, I will keep you posted of the progress.
Malc
 

·
Registered
Joined
·
7 Posts
Discussion Starter #9
Hi
My daughters car has now been fixed, it was a software fault, the software has been updated and it seems to be working fine now, thanks for your help and comments.
Malc
 

·
Registered
Joined
·
4 Posts
Bumping this thread, my unit is doing exactly the same. Blank screen, headunit keeps trying to eject a CD every 10 seconds or so. No resets have worked. I have USB with latest firmware and ready to update but how do I get passed this issue in order to update the firmware? Is there another way?

RT6 unit

Thanks.
 

·
Registered
Joined
·
1 Posts
hi,
I have the same problem with my 308 2012 can you tell me how did you updated the software.
thanks
Hi
My daughters car has now been fixed, it was a software fault, the software has been updated and it seems to be working fine now, thanks for your help and comments.
Malc
 
1 - 14 of 14 Posts
Top