Peugeot Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
91 Posts
Discussion Starter #1
:mad: ...well i thought there might an air lock in the radiator/pipework of my peugeot 307 1.6hdi 2004 plate....becasue of the fan that keeps cutting in (see my other post) so i drained the radiator and coolant and refilled it with new coolant, i also flushed out the radiator by removing the top and bottom hoses just in case there was a blockage and put a hose pipe through it to flush it out.....now as i was driving the engine mangement light comes up and also a message "anti polution fault"....flashes on the screen then goes off...the fan still kicks in more now and its driving me mad...temperature is still normal around 80, car drives fine as well but engine management light stays on all the time...the fan is staying on more and more now...have i messed something up ?...any help and advice..?
 

·
Registered
Joined
·
91 Posts
Discussion Starter #3
can anyone with fault diagnostic equipment read faults or does it have to be peugeot dealers?....how much do peugeot charge ?..any ideas..
 

·
Registered
Joined
·
4,506 Posts
some people hold clones of the dealership diag so can do the same as the dealers, as dealers cost around £45 for half hour or £90 for full hour....bit of a rip of (those are prices for dealers near me)
 

·
Registered
Joined
·
9,733 Posts
goofy gorilla said:
can anyone with fault diagnostic equipment read faults or does it have to be peugeot dealers?....how much do peugeot charge ?..any ideas..
Can`t remember if i asked you yet where are you?
 

·
Registered
Joined
·
91 Posts
Discussion Starter #9
i suppose stoke on trent is the closest but will my car make it there?...drives fine so far with the fan kicking in all the time? will try a local diagnostic bloke first to see if he can do anything, ...cheers
 

·
Registered
Joined
·
91 Posts
Discussion Starter #12
ok - i have now changed the coolant sensor...from peugeot around £15...took the car for a spin , just a few miles...on a dual carriageway...fan didnt kick in.....however drove around my loacl area for a bit....parked my car outside my house fan came on for about 6-10 minutes....took it out again, fan doesnt seem to kick in a lot anymore, just now and then...mind you i had to drain the system out again as there wasnt much coolant in there...anyway filled with coolant around 3 to 3.5 litres and topped up with water...seems to be ok now..fingers crossed...otherwise im selling this car..
 

·
Registered
Joined
·
91 Posts
Discussion Starter #14
chopper1192 said:
How much old coolant came out?
actually there wasnt much in there, about 1/2 a litre because previously i decided to drain all the water and flush out the radiator because i thought there might be some kind of blockage/air lock.....anyway...once the sensor was fitted i drained the system again...and put the amount said...then topped up with water...is that too much ?..
 
1 - 14 of 14 Posts
Top