Peugeot Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
When I turn on the ignition key, the MFD prompted Eco Mode activated. Car starts ok. But I'm dead sure I switch off all electricals.

Next, all the buttons controlling radio/CD, menu, trip, clim etc are not working. But I can turn on the radio w the main knob (top left hand corner) and control the radios/CD via remote stick at the steering wheel. All fuses checked ok.

Any resolution to the above problem?
 
J

·
Guest
Joined
·
0 Posts
For Economy Mode to come on, there must be a power draw there somewhere, and perhaps something in the radio if none of the buttons are working.

A PP diagnostic could check the radio for faults, and even check the operation of the buttons :nod:
 

·
Registered
Joined
·
14 Posts
Discussion Starter #4
For Economy Mode to come on, there must be a power draw there somewhere, and perhaps something in the radio if none of the buttons are working.

A PP diagnostic could check the radio for faults, and even check the operation of the buttons :nod:
Strangely the power button to turn on the radio works, so are the remote control stick. But all other buttons don't work. Sigh.

Looks like a trip to Pug dealer is nec and here in Singapore, they charge :nono: just for diagnostic. I hope I do not need to replace the whole radio unit.
 
J

·
Guest
Joined
·
0 Posts
That isn't just Singapore, they all charge for diagnostic in UK, no matter what garage/dealer you go to :nod;
 
D

·
Guest
Joined
·
0 Posts
Remove the display and disconnect and reconnect it after a few minutes.
 
1 - 6 of 6 Posts
Top