Peugeot Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Hey all
Recently got myself a 2006 Peugeot 407 2.2L Petrol. When I got it, the engine light was on so I did a scan and it's saying code P0105 - Manifold Absolute Pressure/Barometric Pressure Circuit. I cleared the codes (just incase it was old information), drives okay for 5-10 mins maybe longer but then the engine light comes back on again. Same code so I thought I buy a brand new MAP sensor. However when I installed the new MAP sensor, started the car up, the revs was just going crazy in Park like up and down, up and down then around 10-15 secs later the engine light comes on but says a o2 issue (however this doesnt show up with the old MAP sensor) so where would I be looking? I'm not too sure if its a faulty map sensor (getting a new one) or do I have to reset the ECU when changing this? I cleaned the TPS (but havent tried driving yet) and next up throttle body.

Any suggestions would be good. Cheers
 

·
Registered
Joined
·
201 Posts
Hey all
Recently got myself a 2006 Peugeot 407 2.2L Petrol. When I got it, the engine light was on so I did a scan and it's saying code P0105 - Manifold Absolute Pressure/Barometric Pressure Circuit. I cleared the codes (just incase it was old information), drives okay for 5-10 mins maybe longer but then the engine light comes back on again. Same code so I thought I buy a brand new MAP sensor. However when I installed the new MAP sensor, started the car up, the revs was just going crazy in Park like up and down, up and down then around 10-15 secs later the engine light comes on but says a o2 issue (however this doesnt show up with the old MAP sensor) so where would I be looking? I'm not too sure if its a faulty map sensor (getting a new one) or do I have to reset the ECU when changing this? I cleaned the TPS (but havent tried driving yet) and next up throttle body.

Any suggestions would be good. Cheers
Did you read the codes with a standard OBD
reader or Lexia?
 

·
Registered
Joined
·
7 Posts
Discussion Starter #4
I'm in Australia and the standard reader and software says its compatible. Still strange how it plays up with a new map sensor
 

·
Registered
Joined
·
7 Posts
Discussion Starter #6
Got a new map sensor again and still the same symptoms.. gives me P1160 and P1161 but with the original map sensor it doesnt give those symptoms except Manifold Absolute Pressure/Barometric Pressure Circuit.. now the funny thing is I can drive around when cold, and then drive around town when its warmed up.. it wont come on instantly.. although it takes a good 30 mins of driving for it to come back on.. damn mental thing lol
 

·
Registered
Joined
·
201 Posts
Got a new map sensor again and still the same symptoms.. gives me P1160 and P1161 but with the original map sensor it doesnt give those symptoms except Manifold Absolute Pressure/Barometric Pressure Circuit.. now the funny thing is I can drive around when cold, and then drive around town when its warmed up.. it wont come on instantly.. although it takes a good 30 mins of driving for it to come back on.. damn mental thing lol
Change O2 sensors.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #10
trying to find where the o2 sensors are cause i cant see any around exhaust manifold behind the engine on the 2.2
 

·
Registered
Joined
·
201 Posts
trying to find where the o2 sensors are cause i cant see any around exhaust manifold behind the engine on the 2.2
Front right wheel hub there you should be able to see the top one. The other one should be straight forward just jack the car up
 

·
Registered
Joined
·
7 Posts
Discussion Starter #12
at the moment, its running alright.. reseted ecu, cleaned throttle body and engine light hasnt come on after driving around in town and freeway driving... gonna do some more driving to double check.
 
1 - 12 of 12 Posts
Top