Peugeot Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I recently bought a 207 SW HDI (90). It seems to run well with adequate power and is a good starter. I haven't donn enough miles to check the mpg though.

It always shows 'antipollution faulty' on star-up but never when running. The EM light is working but does not come on. A (cheap) EOBD reader reported 3 faults, including P0104 - MAF circuit intermittent. It would not clear this fault.

After several hours of reading on here I came across a short post by Bettyswallocks suggesting disconnecting the MAF Sensor to see if it causes a power reduction. I tried this and found it made no difference to the car's performance.

Presumably, I need to replace the MAF Sensor.

At the risk of sounding dense, is it really that simple?

Comments or opinions are most welcome. Thanks.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
So, £46 lighter but the MAF Sensor is replaced. Performance has definitely improved and (after I cleared the stored codes) the antipollution warning has not reappeared.

So thanks for the reassurances.

That just leaves the matter of code P1351 - IDM (Ignition Diagnostics Monitor) input circuit malfunction. I hope it is the pre-heat relay and/or power feed rather than the glowplugs.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
P1351 is not always a fault it can be ignored if you have no DPF.
Thanks for that. No DPF so no regen to worry about.

I thought the glow plugs still played a part in bringing the engine up to temperature from a cold start-up, or is this not relevant?

Also, could this fault code not point to one or more glowplugs not working, or even the relay?
 
1 - 8 of 8 Posts
Top