Peugeot Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi everyone,

I've recently purchased a 307 x-line 2007, it's pretty old so it's bound to have some problems, so far I've had to change the brake light switch, the brake pads and now I think there seems to be a problem with the electrical system. Basically, the low oil pressure sign comes up with the stop sign, naturally I looked at the engine oil level and the level is good, however now the sign is also accompanied with the emmisions light control sign on the dashboard. There are many things I think it could be, such as maybe wrong oil, oil filter needs changing, or too much oil? I'm afraid it might be the engine as this can be costly and I'm currently a full time student. What you guys think this could be? As it's my first car I'm not very good with the mechanics, any help would be greatly appreciated.

Many thanks,

Mimi
 

·
Registered
Joined
·
5,916 Posts
Oil Level & oil pressure are two different things. Oil level obviously depends on the amount of oil in the sump while oil pressure is a function of the oil pump and / or blockages / leaks in the oil system. If you mean the Oil level display on the dashboard then it could simply be a faulty sensor. It's a pretty common problem on older models especially the 307 and well documented on the forum. As long as the actual level is right then there should be no problems even if the electronic level sesor says otherwise.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Thank you for your help. It's not the oil level sign on the dashboard, it's the STOP warning and it reads OIL PRESSURE TOO LOW, when I'm at low gears or braking to stop. Maybe the oil pump? Or does this still resemble the common electrical faults with the 307? Thanks
 

·
Registered
Joined
·
292 Posts
Thank you for your help. It's not the oil level sign on the dashboard, it's the STOP warning and it reads OIL PRESSURE TOO LOW, when I'm at low gears or braking to stop. Maybe the oil pump? Or does this still resemble the common electrical faults with the 307? Thanks
Does it happen once the engine is heated ? I face same issues...hoping oil\filter will sort it out...

Sent from my Redmi Note 4 using Tapatalk
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
Yeah same, once it's heated up. Really? I'm going to try that too before I try the sensor, let me know how yours goes, I'll keep you updated
 
1 - 5 of 5 Posts
Top