Peugeot Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Hi All,

I have a little problem with my 407 I think I know what has caused it but just need some advice, She was running a treat never had any issues with her, towed the caravan a good 120 miles in the last two weeks no issues.

However, going to work this morning I had 50-60 miles in the tank by the time I got to out skirts of Peterborough that had dropped to just over 20 (this is normal due to the constant stop and starting due to the traffic and roundabouts) so was going to fill up on the way home. I went to over take a car and suddenly had no power at all, the fuel gauge had dropped to a "--" reading so I made my way to the petrol station, I put a quick £10 in as it was over £1.40 thinking I would fill up on the way home. got back in the car and all was well, 3 miles later going in to the city centre I couldn't go over 30 and the car was in limp mode. I got in to the car park turned the car off and on again to get the lovely message of Depollution System Faulty. so tonight after reading a few bits on here I went to the garage and added some redex dpf cleaner and filled the tank.

it was fine again for about 2/3 miles and then lost the power again, if I turn the car off for a minute / two minutes and go again its fine until it registers the error.

Any ideas or is it just a reset through PP?

Thanks

Paul
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
having a look on euro now, haven't got a PP does anyone know anyone close to Bourne or Peterborough
 

·
Registered
Joined
·
1,024 Posts
"anti pollution" is a generic message that is shown for dozens of different and unrelated underlying problems. Therefore you really do need to get it onto diagnostic to find out exactly what it's complaining about.

My guess would be fuel filter too (leading to low rail pressure). But without the diagnostic that really is just a guess.
 
1 - 4 of 4 Posts
Top