Peugeot Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi all, i have tried searching for this problem online with no joy, hoping someone here can point me in the right direction for a fix.

However the storey goes, i have a 2004 swb boxer 2.0hdi non intercooled, with low mileage (55k) i have given it to the mechanic and he has done his best(full service change of all oils filters etc) but still having problems.

Problem is that its running sluggish under 3k rpm, but on or around 3k it picks up and becomes a rocket, also fuel is not brilliant either. Further to it cruising at 70 on the motorway and occasionally it will die off to 50mph then come back an run again at 70 for a while.

Things we have done other than service is ran egr cleaner, injector cleaner and had the egr off (was clean and free to move) now we are scratching our heads as to what is wrong. Any pointers or links would be appreciated.

Regards gareth

Sent from my ONEPLUS A3003 using Tapatalk
 

·
Registered
Joined
·
14,964 Posts
If the turbo is a vacuum controlled system check the vacuum is stable as this is by far the most common issue for lack of power also try running it with airflow sensor/maf unplugged
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Ill have a check of tge vacuum lines, how do i check for. It being stable? Also what should i look for when running with the maf unplugged? Thank you for the reply

Sent from my ONEPLUS A3003 using Tapatalk
 

·
Moderator
Joined
·
6,000 Posts
Also worth a squirt of oil into vac pump as non return valve can stick, or it did on my old 2.0 hdi with same symptoms
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
Jusr tried it with the maf unplugged, and it tan very well, so ill order a new one and see if thats the fix. Im off to work for a few days but will check the other bits mentioned to make sure, but than you for the advice

Sent from my ONEPLUS A3003 using Tapatalk
 
1 - 5 of 5 Posts
Top