Peugeot Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
48 Posts
Discussion Starter · #1 ·
Hello to all
I am a new member and i have a 2002 607 HDI 1997cc with a few problems:confused: on my dash the engine diagnostics is on plus i get beeps with ESP/ASR inactive ,particulate emission system filter needs cleaning,and now the safe mode has cut in ie:2500rpm max plus on the way home the engine cut out but restarted after a 10sec rest and now loss of power.
could this be a local garage or a dealership job(ouch)
many thanks for some advice
 

·
Registered
Joined
·
48 Posts
Discussion Starter · #3 ·
Hello
I have booked the car in to get fault codes on Saturday.hopefuly will not have to take it to main dealer for repair.will post codes A.S.A.P.
thanks for advice
 

·
Registered
Joined
·
48 Posts
Discussion Starter · #4 ·
Hi
I have had the codes read,so many they have reset them all and said if the fault comes again to bring it back and get a free recheck,but they did say that the fuel solonoed was reading weak pressure,cost would be about £160 ouch.
and the particulate filter mite cleaning/replacing.any info would be helpful
thaks Les
 

·
Registered
Joined
·
48 Posts
Discussion Starter · #5 ·
Hi
I have now done about 10 miles since having codes reset.
some have come back on,they are the engine diagnostics light,particulate emission, ESP/ASR,does any one know what needs to be done to cure these problems/warnings,
thanks Les.
 

·
Registered
Joined
·
48 Posts
Discussion Starter · #6 ·
Low power/cutting out

Hi
I checked service history and found out that part of my problem mite be blocked filters as the last owners report did not say they had been changed,
plus the oil the last service used was 20/40w when the recommended is 5/40w.
so i am having a service done ie:all filters/belts/tension pulleys/water pump at a cost of about £400/450,can any one advise is this reasonable,
Thanks to all Les.
 

·
Registered
Joined
·
1,002 Posts
Hi Leslie,

You need to get the particulate filter cleaned and the oil resovior regenerated..

the process involves replacing the particle filer which is a bottle like filter made of high grade alluminium..

It cosst £500 on its own but garages can give you a refurbed one (which is cleaned professionally) for £250 providing they keep the old one..

the oil is £17 a litre and it requires around roughly 7 litres, depending how much you need..

then the car needs to be told via PSA Diag that the filter has been changed and regenerated..

after all this work, it is still quite normal for the warning lights to show up again for a few weeks..

TBH £400 is fairly reasonable.. we would charge folk around £600-700

are you getting it done from a Peugeot garage..

My advice is NOT to go anywhere else.. as the warnings and problem still remain..
 

·
Registered
Joined
·
48 Posts
Discussion Starter · #8 ·
Scotcruz said:
Hi Leslie,

You need to get the particulate filter cleaned and the oil resovior regenerated..

the process involves replacing the particle filer which is a bottle like filter made of high grade alluminium..

It cosst £500 on its own but garages can give you a refurbed one (which is cleaned professionally) for £250 providing they keep the old one..

the oil is £17 a litre and it requires around roughly 7 litres, depending how much you need..

then the car needs to be told via PSA Diag that the filter has been changed and regenerated..

after all this work, it is still quite normal for the warning lights to show up again for a few weeks..

TBH £400 is fairly reasonable.. we would charge folk around £600-700

are you getting it done from a Peugeot garage..

My advice is NOT to go anywhere else.. as the warnings and problem still remain..
:nod: h

Hello to all
sorry for o so late reply,I have been busy moving home.
had the tank regenerated and reset,seems to run ok apart from being a bit sluggish and pulling back sometimes like a miss fire although she is a diesel
any ideas what would cause this.
 

·
Registered
Joined
·
1,002 Posts
leslie said:
:nod: h

Hello to all
sorry for o so late reply,I have been busy moving home.
had the tank regenerated and reset,seems to run ok apart from being a bit sluggish and pulling back sometimes like a miss fire although she is a diesel
any ideas what would cause this.
did u get it done from the main dealer.. even if the work is done, the car needs to be told that the work has been done via PSA (aka peugeot planet)
 
1 - 9 of 9 Posts
Top