Peugeot Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
55 Posts
Discussion Starter · #1 ·
Bit of a follow on from my other post really.

The LCD disdplay on ther dash works but the back light don't hence i can't see anything unless i am six inches away.........not ideal driving conditions.

I cant work out what is the 12v supply to the lights, anybody know, or better still any body know why ther are no lights.

I have changed the bulbs and metered them out, all ok
 

·
Registered
Joined
·
55 Posts
Discussion Starter · #2 ·
I have removed the LCD display and stripped down (as descrobed in another post). Removed the PCB and display from the housing plust the board that holds the small bulbs.

I have 11.6 volts at the track for the illumination bulbs bur none of the six bulbe i have work.
I have checked th resistance across the bulbs contacts and it's open circuit but i am not sure if you would get a resistance accross these little things.
I know the voltage is a little below the 12v but they shoud still light up
 

·
Registered
Joined
·
55 Posts
Discussion Starter · #4 · (Edited)
The dimmer switch is up full, at least the dash light are.

I followed a Post here to crazyleds and have ordered some 12v wedge leds that will fit.
It can only be contact thats at fault or blown/damaged bulbs. Leds are better anyway.
Will await them and let you know how it goes
 

·
Registered
Joined
·
55 Posts
Discussion Starter · #5 ·
I have illumination !!!, got my led's from crazyleds and all is working.
Gotta say that crazyleds are fast on delivery.
One other question should all the display be at the same brightness, the date is birghter that the the temperature and the time.
The radio station are all bright.
Seeems a small thing as i had SFA before but thought i would ask
 
G

·
Mine used to have a darker corner, mainly because one of my led's wasnt sitting correctly, bit of a wiggle and off we go!

But yeah you cant go wrong with crazyleds, got reccomended them to get my blue dash gear from and have suggested them to everyone else since! :thumb:
 

·
Registered
Joined
·
9,731 Posts
kenledger said:
My problem with it being dim on one side was an led not working, i am all bright now :D

Got one more problem to sort and thats an air bag fault indicated
Hope thats not your comm 2000 but if it is you can take the top half of one with an indicator problem and join the two if they have the same coloured wires.:thumb:
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top