Peugeot Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Hi all

Drove my car say 50mph and ok then stopped at a junction, pit foot on accelerator and lagging power feels like a blockage no instant power

Any suggestions what I could look at that might be the problem. Throttle unit,????

Anyone with help much appreciated

Have Peugeot 207 1.4 SW estate 57 reg
 

·
Registered
Joined
·
61 Posts
Could be a a number of things, worth checking to see if the engine ecu has recorded a fault by checking for fault codes with a fault code reader, will give you an indication of where to start at least.
 

·
Registered
Joined
·
61 Posts
Is the fault intermittent? If The fault can be replicated then a diagnostic plug in would be the best plan of action to watch real time data so you can see exactly what the ecu is seeing from the vehicles various sensors and look for any suspicious readings that appear to be incorrect for the current demand on the vehicle, in my opinion its the best way to avoid throwing money at parts. I've come across a fault like this before but on a Nissan xtrail, stopping at junctions or traffic lights then pulling away with poor performance and turned out to be the suction valves in the high pressure pump but every vehicle needs to be checked as a seperate case and subject to the same rigorous testing methods by trained individuals to avoid the as above, wasting money... You could have a fuel delivery problem, turbocharger issues, Intake problems etc etc Cheers
 

·
Registered
Joined
·
9 Posts
Discussion Starter #5
yes it is intermittent. As you state, does my vehicle have the suction values/high pressure pump and if so or similar, where can I find it to check/replace?
 
1 - 7 of 7 Posts
Top