Peugeot Forums banner

1 - 16 of 16 Posts

·
Registered
Joined
·
39 Posts
Discussion Starter #1 (Edited by Moderator)
Hi guys,

Well my Peugeot 207 1.6 HDI 2006, is suffering with a knock at the front.

It’s had a knock ever since I’ve owned it, but seems to be slightly worse! I’ve changed both ARB droplinks and both lower ball joints, no change.

I would change the ARB bushes but they seem a nightmare to get too.

Could it possible be the engine mount? I put a crowbar between the engine and it was able to rock very easily from the top mount, but I thought if the mount was going it would shudder on acceleration?

I just have a knock which I can feel through the front of the car, mainly at low speeds over bumps.

Also, after changing the lower ball joints the steering wheel is no longer completely straight, is it just the tracking needed to resolve this?

Thanks in advance
 

·
Moderator
Joined
·
6,572 Posts
Have you checked strut top mounts these do fail on 207 as do inner track rod ends (not as common as top mounts)

Yes tracking may need doing likely after market ball joints/lower arms are slightly different dimensions strange as it very rare to affect wheel as it's normally only a slight amount.
 

·
Registered
Joined
·
39 Posts
Discussion Starter #3
Hi yes I’ve checked the top mounts of the struts, I’ve tried to rock them and they make no noise! It’s hard to explain, it knocks but when it knocks it feels like the handling goes lighter
 

·
Moderator
Joined
·
6,572 Posts
Could be a faulty strut. There was a recall on 208's for a front end knock due to faulty shocks.

I would check strut tops again, jack up car and feel around top of strut. My daughters old 207cc got a slight knock, there did not appear to be any play but when i felt around strut top the out ring had started to fail on top mount bearing and shed a few balls. As i stripped the strut the top mount fell apart
 

·
Registered
Joined
·
35 Posts
Could it possible be the engine mount? I put a crowbar between the engine and it was able to rock very easily from the top mount, but I thought if the mount was going it would shudder on acceleration?

Just a "thinking outside of the box" idea.....have you checked the torque engine mount at the bottom of the engine? It is the one that prevents it rocking.


I have a similar problem, in that the engine does "rotate" all too easily, and there is a knock from the front. However in my case the engine shudders a bit at idle. I am just about to replace that mount today.


Also - I have no issues with the steering going "light" as you describe. So this is why I am saying it is an "outside the box" idea.
 

·
Registered
Joined
·
39 Posts
Discussion Starter #6
Thanks guys, think I’m going to start with the right engine mount and then see what happens from there.

I probably will do the torque mount too as it’s only £15, just looks difficult!
 

·
Registered
Joined
·
35 Posts
Thanks guys, think I’m going to start with the right engine mount and then see what happens from there.

I probably will do the torque mount too as it’s only £15, just looks difficult!

Including putting the car on a pair of ramps, took me about 20 mins this morning to do the torque mount. It is easily accessible, just two 17mm bolts (in my case). Both nuts are "captive".

Real issue was lining it back up, I simply jacked up the front of the engine a bit until the holes lined up, and wiggled the bolt through. It seemed easier to do the back bolt first, then line the engine bracket up with the front of the torque bar using the jack.

One thing I did notice, where the engine has been rocking it has broken the exhaust mount brackets nearest the engine. Had to spend 5 mins doing a temp wire job on it. Will suffice until exhaust blows a hole and we have to replace it. I am certain that was the actual source of our knock.
 

·
Registered
Joined
·
39 Posts
Discussion Starter #8
Well that’s the top right engine mount done, probably needed doing no engine movement at all but hasn’t stopped the knock!

I can’t really explain the knock, it feels as though it’s the driveshaft wobbling but I’ve checked it and it’s all secure...

I think next step is the rear lower engine mount for the sake of £15.

I have some lowering springs to go on, so may possibly get some new shocks front and rear, do I need a top strut mount kit too?
 

·
Moderator
Joined
·
6,572 Posts
If you are stripping the struts just change the top mount bearing at the same time a lot cheaper than the whole top mount
 

·
Registered
Joined
·
39 Posts
Discussion Starter #10
Right new lowering springs on, new bearing on shock absorber and...

Knocking is still there...

That’s coil springs done, anti roll bars, lower ball joints, right engine mount done,, think I’m running out of options!

The knocking is only at low speed, cannot hear it otherwise.
 

·
Registered
Joined
·
39 Posts
Discussion Starter #13
Whilst replacing the front springs and struggling to get the strut out I’ve managed to knock something so the ABS light has come on, does anyone know what I could have knocked?
 

·
Registered
Joined
·
876 Posts
not sure on space but i have wedged a bit of windscreen wiper rubber under frames and bars in the past, just as a diagnostic to see if noise changed.
 

·
Registered
Joined
·
35 Posts
Hope I am not being patronising here, but when I changed the bottom mount I noticed that due to excessive engine movement, the front exhaust hanging bracket (just aft of the engine, where it is welded to the exhaust) had fractured allowing the exhaust to move about. I am sure (since it has now gone) that this was the course of our knock.

The engine mount was shot to pieces - and probably was the root cause of the broken bracket. The noise did sound forward of where it actually was, and to the left.

All that being said, I am sure you have already checked that sort of thing, but I felt it was worth mentioning in case.


Hope you get it sorted soon, faults like this are bl**dy annoying. I have a rearwards knock on my Mondeo, took me ages to work it out, but using "stripe88"'s method of wedging a bit of rubber in this afternoon I found it. Turned out to be rear anti roll bar mount, so roll bar is knocking - so big thanks to Stripe88 !
 
1 - 16 of 16 Posts
Top