Peugeot Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi guys,

I totally apologise if this has been asked before or if I have posted in the wrong section!

But I'm having issues with my 2002 Peugeot 307 2.0i 16v XSI, issues are:
1) Lacks power.
2) Back fires when revved and when changing gears.
3) in idle - if you gently touch the accelerator - the rev counter drops slightly and almost cuts out.
4) Rough Idle.
5) Hesitant.

I took it to a local garage who stated it was an injector(s) 1 and 2, so had these replaced as it was displaying the codes for injectors 1 and 2! But this did not fix the issue - so they recommended that I had the 3rd and 4th injector replaced, so I did! But this did not work! So they recommended I replaced the spark plugs - which they did, this did not work either! Then they said they needed to change the exhaust (full inc catalytic convertor) - so I told them to do it!

Picked the car up friday and it is running exactly the same :mad: - so asked them why, they answered 'we do not know now' (great), so I took the car home even worse than when it first went in! I really do not know what else to do? As had all the work done that they told me was needed! Do you guys have any clue as to what my next steps would be?

Thanks guys
 

·
Registered
Joined
·
4,778 Posts
Hi guys,

I totally apologise if this has been asked before or if I have posted in the wrong section!

But I'm having issues with my 2002 Peugeot 307 2.0i 16v XSI, issues are:
1) Lacks power.
2) Back fires when revved and when changing gears.
3) in idle - if you gently touch the accelerator - the rev counter drops slightly and almost cuts out.
4) Rough Idle.
5) Hesitant.

I took it to a local garage who stated it was an injector(s) 1 and 2, so had these replaced as it was displaying the codes for injectors 1 and 2! But this did not fix the issue - so they recommended that I had the 3rd and 4th injector replaced, so I did! But this did not work! So they recommended I replaced the spark plugs - which they did, this did not work either! Then they said they needed to change the exhaust (full inc catalytic convertor) - so I told them to do it!

Picked the car up friday and it is running exactly the same :mad: - so asked them why, they answered 'we do not know now' (great), so I took the car home even worse than when it first went in! I really do not know what else to do? As had all the work done that they told me was needed! Do you guys have any clue as to what my next steps would be?

Thanks guys
http://www.peugeotforums.com/forums/introductions-28/brief-faq-guide-new-members-83170/
 

·
Registered
Joined
·
50 Posts
Hi what your clutch like. I've got a similar problem to this I own a 307cc 2.0 16v on 2005 . It happens on mine at at around 1500 to 1800 revs mark and after that it fine. It worse in the morning. I have given the car a full service oil plugs air filter and and new sensors what sit on the throttle body to still no avail . I have heard this could be the tappets or clutch . On the other hand my clutch is on it way out I have smelt it a few times what the millage of your car. . I will hopefully be changing the clutch next weekend let hope it solves it. P's your not the only one with this fault no body seems to know the answer to it
 

·
Moderator
Joined
·
5,891 Posts
Sounds like its running weak, check intake system for leaks,

One simple check is to spray WD40 around inlet manifold area with engine running revs will rise if WD40 is sucked into engine.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #6
Thank you all so much, I will have a look tomorrow and update you all further on my findings - also to the person who asked about my clutch, it was replaced about a year ago and feels fine! Thank you all
 

·
Registered
Joined
·
3 Posts
Discussion Starter #7
Just an update, still no luck - have had it in a garage all day today who can't pin point anything.... So now it's booked in with Peugeot for a full diagnostic 😒!
 

·
Registered
Joined
·
50 Posts
Just an update, still no luck - have had it in a garage all day today who can't pin point anything.... So now it's booked in with Peugeot for a full diagnostic 😒!
Hi did you sort you issue . I found out the problem to my car by accident lol. I went and changed the cam belt plus the kit water pump etc and why I was at it I changed the auxiliary belt and all the pullys etc. Any way I put the car back together and the car . Runs like a dream pulls off nice using just the clutch etc . My guessing is that I have no idea when the timing belt was done but I'm guessing my felt was stretched which would knock the timing out

I hired the timing lock off pins for mine cost me 12 quid with £170 deposit refundable the full cam belt kit and auxiliary kit all in total a few quid just over £150 and I fitted it my self.
 
1 - 10 of 10 Posts
Top