Peugeot Forums banner
61 - 79 of 79 Posts

·
Registered
Joined
·
125 Posts
Thanks a lot you are being of great help both; looking aroung got a price for a genuine BorgWarner at £795+VAT (£954).
So in conclusion do you advise to keep the original turbo and just change the actuator for the time being? When they did the pressure test, it was very slowly loosing pressure so they think that is a common issue with this type of turbos....
 

·
Registered
Joined
·
26 Posts
Hi! Thanks for your feedback.

Mine situation is slightly more peculiar.

Was a 156THP that was upgraded to a 175THP turbo. This upgrade was matched to a larger intercooler, hi-flow cat, Bastuck exhaust. Also remapped to approx. 200bhp with this setup.

Being hungry for more power, a hybrid turbo good for 250bhp was sourced.

Prior to fitting this 250bhp turbo, several items were changed/done - leaking engine valve cover+intake pipe, new turbo vacuum pump, spark plugs and also intake valves sandblasted. The 175THP turbo ran very well with the afore-mentioned. The remap was running at 20-21psi max with brisk acceleration and feather light throttle response.

The new 250bhp turbo was fitted, but it refused to go to 20psi! It gets to 10-11 psi and gets P0299 (underboost) and goes into limp mode.

No air leaks, diverter not faulty, turbo is not faulty. Yet it underboosts. Quite frustrated. :(
Hi all, an update on my boost issues.

It has been resolved. On my 1.6THP

I replaced the boost vacuum hoses with silicone hoses. From the turbo brake boost pump to the boost control solenoid and the boost control solenoid to the wastegate actuator.

I'm back to boosting about 20psi as on my tuned file and am ready to get tuned for my 250bhp turbo!
 

·
Registered
Joined
·
26 Posts
Its now after 1 mth of replacing the silicone vacuum boost hose.

In the first 2 weeks, it was boosting really well, firm throttle, sudden heavy throttle and the boost comes on in every gear.

In the 3rd week, firm throttle was ok but seemed slightly sluggish. As for sudden heavy throttle, it went into limp mode with P0299 again. Error codes were erased using Torque on android and it was ok again. There was boost but sluggish when error was prompted.

This week, 1 mth, it went into limp mode. Erased but still in limp mode. There is absolutely no boost, unlike the week before. Totally naturally aspirated now.

Would anyone know if its the vacuum hoses? or something else?

Thanks in advance!
 

·
Registered
Joined
·
4 Posts
My 208 had P0299 code a month ago. It turned out to be 2 things, each would bring up the code. First there was some leaks from the hose joint, and after I fixed the leaks, I mostly eliminated the P0299 code. If there is a tiny leak, you get the service light when you bring the speed up moderately in high gear under medium boost almost every time, but only occasionally under full throttle in proper gear.

Then the code came back after a week or so, this time the code happened at random under boost, and it become worse and worse gradually until one day, turbo totally gone. This time, it turned out to be the actuator rod came off completely from the wastegate lever.
 

·
Registered
Joined
·
125 Posts
Dear all, jsut to let you know that my Peugeot 207 GTI 175 THP, remapped stage 1, is still driving great with no further issues after around 1200 miles.

I though it may be useful to other members to summarise what issues I had and how it got resolved as my problems were very common for this car

a) I was getting error code P0087, with stuttering and hesitation especially with a cold engine. That gradually was getting worse to a stage that car was not driving well at all. This was related with the high pressure fuel pump which was faulty. Very common for these engines. Replaced and error gone for good.
b) Error P0299, was coming up to high revs and car was going into limp mode. Mosty was happening to sudden acceleration with 4th/5th gear. Common faults are diverter valve, electrovalve which I replaced with no improvement. Hoses were OK. So next step was the electonic actuator, as again it can be a common issue for these cars, which when I went to replace the turbo specialist noticed cracks in the turbo housing. Replaced whole turbo with a second hand (not reconditioned) with no cracks and good actuator and car is running great now, no issues.
c) Last issue was that when engine was hot, when I was deccelerating (reaching a roundabout) I was getting the message "engine oil pressure low" for 3 seconds and then it was disappearing. This again is apparently a common fault for these engines and usual cause is: dirt in the
The cam oil control solenoid
The cam shaft oil rings
The cam phaser
Mine was the solenoid which I replaced and problem gone.

Now car is in great drivable state so I enjoy it on my... private road :))

Hope that helps
 

·
Registered
Joined
·
4 Posts
Yes, it's a 208 GTi.

And the problem came back just before Christmas. Just had it fixed again, it was another rubber seal.

So far, I had both of the rubber seals broken, each time it will trigger P0299 code and limp mode under heavy boost and high rev (around 6000 rpm). One seal is on the turbo compressor inlet side, another one is for sealing between the hose just before intake manifold and the hard plastic pipe on top of the engine.

What 208? GTI?
 

·
Registered
Joined
·
125 Posts
Hi all

Was away for a while. Car was great until 10 days ago (Peugeot 207 gti, remap stage 1). Turbo gone, oil was smoking out of it and on top of that one of the cylinders probably is gone. I have it in the my turbo mechanic who is trying to sort it out hopefully for next week. I have bought a "copy" turbo from Germany so it will be educational for all of us to find out how good/ bad the non genuine Borgwarner turbos are. :D

Someone has to to test them after all :eek::eek:
 

·
Registered
Joined
·
125 Posts
So Car is getting fixed. They are changing the turbo, and had to get the engine out to replace one piston that was broken, the exhaust seal valves, the exhaust camshaft and the timing chain.
Hopefully it will be ready by the end of this week. Will let you know
 

·
Registered
Joined
·
276 Posts
Must admit even though I don't have a Peugeot anymore have been interested in following your car but by now wouldn't it have been cheaper just to have bought a replacement car?
 

·
Registered
Joined
·
125 Posts
Well, I have bought already a 208 gti :lol: which I love to bits. However all the repairs will not cost more than £800-900 and then it will be fully refurbished. Let alone I want to check the chinese turbo ;)
 

·
Registered
Joined
·
125 Posts
New K04 turbocharger

Hi to all

I have upgraded my k03 turbocharger yesterday for my Peugeot 208 gti with a Mambatek GTX K04. The swap went smoothly and I am waiting for my car to be mapped now to stage 4 by Stelios-etuners.gr.

I would like to clarify, for the benefit of all, that the turbocharger for the 207 gti and 208 gti are exactly the same (in size), bolt on, no need for any sort of modification. Its really interesting that most of the upgraded K04's are advertised for the 207 GTI and not for 208 gti but in reality they do fit like a dream to the 208 gti.

Anyone looking to upgrade can also look at www.tmg-performance.com that they make a turbocharger for 207gti to reach 310hp, that fits bolt on on the 208 gti aswell (spoke with them and they confirmed that).

When remap is done, I will get it to a rolling road and will let you know the outcome.

Regards
 

·
Registered
Joined
·
1 Posts
[QUOTE = "Doub, сообщение: 1432386, участник: 380306"]
Перед заменой электроклапана я проверю топливный насос высокого давления. Я получаю код P0087 в последние несколько дней, и это, кажется, приводит к недостаточной скорости турбо при высоких оборотах (код ошибки P0299). Я подозреваю, что насос высокого давления не справляется с высокими требованиями. Я испытываю некоторое разбрызгивание при холодном двигателе в первые 5-10 минут утра, что дает код P0087 (не каждый день). Если я стираю код через 10 минут, машина работает нормально до конца дня. Я подозреваю, что это HP HP как общие проблемы с этими двигателями.
[/ QUOTE]
Кod oshibki P0087 Nasos visokovo davleniye benzin nada zametit evo po diagnostike pishit shto v ramke davleniya slishkom niskoe.zamenit etu nasos probleme bolshe nebidit.
87567
 
61 - 79 of 79 Posts
Top