Peugeot Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
86 Posts
Discussion Starter #1 (Edited)
Hi All, it has been I while since I posted, although I checked in once in a while I was busy studying etc. Anyhow, I'm glad to say that I have now owned my 2004 Peugeot 307 1.6Hdi 110 for a year and 1 month now (still loving it).

However recently, I began getting the feeling that the car isn't running completely right. There are not ant-pollution faults showing, no EML lights showing and no mis-fires. EGR has been blanked off a year ago. Engine starts straight away first try in the morning. Having said this, I noticed that there was quite an amount of soot at the back end of the exhaust and consumption has gone a bit worse than usual. I can't see any black/white/blue smoke when driving (flooring it) and even when I got a mate to check it he said that all is clear. I'm not losing any coolant or oil either.

No error codes in PP except EGR (most probably due to blanking)

I have attached some screenshots below showing readings from PP2000. Your feedback is most appreciated. Should the values be as they are?





Injectors at Idle


At around 2500rpm


Sorry for the long post as I tried to include much detail as possible. Maybe I'm just being paranoid

Cheers,
Adrian
 

·
Registered
Joined
·
86 Posts
Discussion Starter #7
Unfortunately only one brand available here, Enemalta..who knows what fuel it is..I use Bardahl diesel additive from time to time.

Serviced 1,000 miles ago by myself. Including Oil and oil filter, air filter and fuel filter and cleaned the MAF using Tuner spray (which I normally use on computer components).

I may just wash the DPF out just for peace of mind to make sure everything is in good nick.

Adrian
 

·
Registered
Joined
·
86 Posts
Discussion Starter #9
This Wurths DPF cleaner is meant to be very good,
I can't see your dpf settings but if the % load is high this stuff will clean it.


Sent from AutoGuide.com Free App
Thanks for your feedback betty. It doesn't seem that the DPF is actually blocked though.

Particle filter emmission load: 18%
Exhaust diff pressure at idle 0Mbar
Exhaust diff pressure at approx 2.5K: 12Mbars

Does the above suggest that it is blocked? (To my limited knowledge it seems that it is ok).

I have already bookmarked the thread for the leak-off test, scheduled for saturday morning :thumb:
 
1 - 9 of 9 Posts
Top