Peugeot Forums banner

1 - 19 of 19 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1
Hi all I have just bought an 806 and am frustrated by the indicators. All of a sudden they stop working,no amount of jiggling the stalk helps ( thought it may be a bad connection as its been stood awhile) can work normally most of the time then just when you need them nothing!!! Help
 

·
Registered
Joined
·
4,779 Posts
Hi all I have just bought an 806 and am frustrated by the indicators. All of a sudden they stop working,no amount of jiggling the stalk helps ( thought it may be a bad connection as its been stood awhile) can work normally most of the time then just when you need them nothing!!! Help
Is it a comm 2000 delphi by any chance if so try with side lights or dipped beam on and if it works like that I can fix it, Google my phone number 07599587119
 

·
Registered
Joined
·
192 Posts
Whereabouts are you Rick?

The problems I've experianced on every 806/Synergie/Ulysee that I've owned apart from the latest one I just bought, is the indicator stork gets iffy and you'll sometimes hear the flasher unit/relay clicking as though the indicators are still flashing. Sometimes the contact cleaner has sorted it, other times I've changed the switch.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #14
Whereabouts are you Rick?

The problems I've experianced on every 806/Synergie/Ulysee that I've owned apart from the latest one I just bought, is the indicator stork gets iffy and you'll sometimes hear the flasher unit/relay clicking as though the indicators are still flashing. Sometimes the contact cleaner has sorted it, other times I've changed the switch.
Hi I'm residing in the Kentish Town Royal Tunbridge Wells.
 

·
Registered
Joined
·
27 Posts
Thanks all but it turned out to be the relay!!
i was going to say, "have you checked the relay but i thought i was being like :bang:"

like they say, always check fuses first and then relays, then get the hammer.

for the people who look at in future...

how did work out the indicators relay was the problem?

and if you did a swap with another relay, do you know which one you swap it with.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #18
Ah thanks but how do you identify it
Basically I started to take off the binnacle around the column to see if I could get access to the switch after removing the bottom half I noticed the relays,as soon as I touched one the indicator started working! Aha I thought bad connection, removed the relay cleaned the connectors and replaced but still intermittent unless I kept pressure on the relay. Problem diagnosed getting new relay tomorrow.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #19
i was going to say, "have you checked the relay but i thought i was being like :bang:"

like they say, always check fuses first and then relays, then get the hammer.

for the people who look at in future...

how did work out the indicators relay was the problem?

and if you did a swap with another relay, do you know which one you swap it with.
The relay is the smaller of the two facing you under the column and fitted on the left of the two
 
1 - 19 of 19 Posts
Top