Peugeot Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
364 Posts
That actually means that the ECU is not getting a proper signal from a camshaft position sensor on one of the camshafts (whichever is classed as track 2), the cause is either a faulty sensor or wiring/connectors. Check all connections or failing that a diagnostic on PP/Diagbox should be able to narrow it down.
 

·
Registered
Joined
·
364 Posts
Well fingers crossed I would feel happier if it was put on diagnostics to rule out anything else as sometimes these codes don't always literally mean what they say and VVT does sometimes have hydraulic issues that could possibly flag up the same code it depends on how the ECU has been programmed at the factory. Cam sensors do give a lot more problems than the VVT system and I would have thought there would be other codes if the VVT itself was at fault but always err on the side of caution.
 

·
Moderator
Joined
·
6,448 Posts
What oil is in the car, wrong grade oil, VVT solenoids/motor and loose chain/tensioner issues can all trigger that error code
 

·
Registered
Joined
·
870 Posts
i was thinking more essentric shaft sensor, on the bmw engine they tend to let oil through, take the top of it and check and clean.

on the vti its at the rear right of engine when stood at the front of the car, google.... Valvetronic Eccentric Shaft Sensor.

i would also unwind the valvatronic motor out with a allen key in the rear of it, check its not gunked up.
 
1 - 10 of 10 Posts
Top