Peugeot Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
Hi i have an intermittent engine light on a 1.9d partner that only shows when you labour the engine by changing up a gear too quick and applying full throttle. It comes on and if you lift your foot off the throttle it goes off in about 5 secs. It doesnt do this when driving normally giving the van plenty of revs before going for the next gear and it drives perfectly. Its behaving a bit like a pollution light or maybe showing up an egr fault. I changed the timing belt a few days ago but i cant be sure it wasnt doing this before that. Im just wondering if the pump timing is slightly out
 

·
Registered
Joined
·
914 Posts
Grenadekid said:
Hi i have an intermittent engine light on a 1.9d partner that only shows when you labour the engine by changing up a gear too quick and applying full throttle. It comes on and if you lift your foot off the throttle it goes off in about 5 secs. It doesnt do this when driving normally giving the van plenty of revs before going for the next gear and it drives perfectly. Its behaving a bit like a pollution light or maybe showing up an egr fault. I changed the timing belt a few days ago but i cant be sure it wasnt doing this before that. Im just wondering if the pump timing is slightly out
could be anything... you need to scan the codes using diag2000

sounds like blocked filter, could be turbo..
 

·
Registered
Joined
·
492 Posts
Grenadekid said:
Hi i have an intermittent engine light on a 1.9d partner that only shows when you labour the engine by changing up a gear too quick and applying full throttle. It comes on and if you lift your foot off the throttle it goes off in about 5 secs. It doesnt do this when driving normally giving the van plenty of revs before going for the next gear and it drives perfectly. Its behaving a bit like a pollution light or maybe showing up an egr fault. I changed the timing belt a few days ago but i cant be sure it wasnt doing this before that. Im just wondering if the pump timing is slightly out
I'm guessing your timing is off alittle.... Best thing is to get codes read...:)
When you start up is it running rough....??
Ron.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #4 (Edited)
risky1 said:
I'm guessing your timing is off alittle.... Best thing is to get codes read...:)
When you start up is it running rough....??
Ron.
Thats the thing ron it runs perfectly normal when cold and warm and even drove it up to 80 with no hesitations or flat spots etc.

Scotcruz and ron i hooked up my own scanner yesterday but no fault codes although i have no faith in this scanner as i think its not linking properly to van even though it says it is. Cant be turbo as its only 1.9 non turbo, which filter do you mean is blocked. I changed the air filter yesterday and she got a full service with fuel filter Thanks for the replys guys
 

·
Registered
Joined
·
914 Posts
Grenadekid said:
Thats the thing ron it runs perfectly normal when cold and warm and even drove it up to 80 with no hesitations or flat spots etc.

Scotcruz and ron i hooked up my own scanner yesterday but no fault codes although i have no faith in this scanner as i think its not linking properly to van even though it says it is. Cant be turbo as its only 1.9 non turbo, which filter do you mean is blocked. I changed the air filter yesterday and she got a full service with fuel filter Thanks for the replys guys
if you cant get any codes or warning on display then it could be anything mate...

common warning with engine management light is the DPF diesel particle filter.. which is under the vehicle.. google DPF or particle filter in image..
 

·
Registered
Joined
·
492 Posts
Ther 1.9 diesels don't have dpf's....If your having a "intermittent engine light" on then there has to be faults logged....maybe post your location as there are quite a few members here with planet who maybe willing to help out...:)
Ron.
 
1 - 7 of 7 Posts
Top