Peugeot Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
Another one to add to the saga of blower problems!

I bought a 2005 307 CC recently and have been having intermittent problem with the air con blower (worked perfectly when inspecting the car, of course!).

Sometimes when I start the car it works perfectly, full control of all speeds and cools/heats perfectly. As long as the car remains on it keeps working perfectly, for hours and hours if the drive is that long.

However sometimes when I start up the blower is dead. No amount of turning the speed up or down (or even off on the panel) does anything. I have to keep starting and turning off the car, and eventually it starts working for no apparent reason. The first time I cleaned the fuse in case that was the cause, and it worked straight after. Then again stopped working, and I put a new fuse and all worked.

However, now the fuse poking does nothing and it's random when it will and won't work. I was wondering if it was a failing relay somewhere, but now having read this maybe it's the resistor. However it seems strange that when it works it all works perfectly. All speeds, temperatures, etc.

I haven't been able to find any relays under the fuse box to try replacing.

Does anyone have any ideas? I can try pulling out the resister to check for corrosion on the terminals, but it doesn't fit the symptoms I've been reading about. Possibly a control unit failure instead?

Is there anything like VCDS on VW cars for Peugeot? Something to link ti to a laptop and access control modules directly?

Thanks
 

·
Registered
Joined
·
1,831 Posts
Have you tried removing the plug from the Air recirculation motor to check and see if all is ok? RH drive cars remove the lower facia trim and after undoing the two fasteners remove the centre console side panel (adjacent to the pedals). for access.
 
1 - 4 of 4 Posts
Top