Peugeot Forums banner

1 - 17 of 17 Posts

·
Registered
Joined
·
80 Posts
Discussion Starter #1
hi,my abs light has came on today.ive owned the car since feb and never ever had any bother with her.tonight whilst driving home the red stop was flashing and beeping and the amber abs light was on.i pl,ugged my tool in after finding where it was and it was incompatible.my mate plugged his gucci snap on tool in and it came with "intermittent abs pump error?does this meean my sensors are dirty and need a clean or is it the dearest one in that i need a new abs pump?can anyone help?
 

·
Registered
Joined
·
80 Posts
Discussion Starter #5
?

Hi.the abs light has gone off as well as the red stop light!!does this mean it could be dirty abs sensors on the rear what need cleaning up?cheers.
 

·
Registered
Joined
·
3 Posts
abs pump intermittent fault

Hi there,
I noticed you also had an intermittent abs pump fault. I got code read at peugeot garage and I have same problem. Garage didn't really look properly but said new pump would cost around £900. Been looking online and abs pump seems to be common problem but you are the only one I have found with the same intermittent fault. So just wondered what yours was in the end. Don't want to fork out £900. So I'm crossing my fingers for a loose wire.

Any help appreciated, thanks,
Hayley
 

·
Registered
Joined
·
5,904 Posts
On the 307, it is pretty common that the sensor mounting needs cleaning as it pushes the sensor out of correct alignment. Try using the search and you will find a number of posts relating to this. There is a post with a comprehensive guide on cleaning the sensors.

Without connecting to planet/diagbox it is impossible to say with certainty which sensor(s) are causing the problem but most post that I have read say it is on the rear.
 

·
Registered
Joined
·
158 Posts
I've just bought a pump on ebay for £30, I wouldn't pay £900, that's about the value of my whole car :lol:
Mine is making a grinding or whirring sound when I pull away or go over a deep pothole. A couple of days ago the noise didn't happen, but the stop and abs lights came on. The mechanic plugged in his diagnostic kit, and it said "ABS pump seized, permanent fault". Now the noise is back but the lights are out :confused:
It's being changed tomorrow, weather permitting.
 

·
Registered
Joined
·
3 Posts
Hi thanks for reply,
The car has been on Peugeot diagnostic machine and the error code is "intermittent abs fault". The Peugeot mechanics said this was the abs pump because else it would say abs sensor fault according to them. I don't think they would try and con me as its an old school friend. But I'm surprised the pump can have an intermittent fault, so I was wondering if it could be a corroded wire or something. If the pump was broken wouldn't the abs light still be on.
Any help appreciated,
Thanks, Hayley
 

·
Registered
Joined
·
3 Posts
£30 is a bargain you have done well there. Yes that's what I don't understand if mine was the pump I would have thought it would just seize up like yours. Keep me updated on how the new one goes. How do u find out the exact pump u need? My cars an import so I think some parts are slightly different to normal 1.6 petrols.
 

·
Registered
Joined
·
158 Posts
Mine did seize up temporarily, that's why the ABS light came on. Now it has freed itself again, but it makes a loud whirring noise when I first pull away or go over a deep pothole. Probably the motor is going to die soon.
When the mechanic connected his diagnostics, it came up with the make (BOSCH) and part no. 9651873780.
He came today, but to get at the pump he says the head light and bumper need to come off. Unfortunately it started to rain so he is coming back another day to do it.
 
D

·
Guest
Joined
·
0 Posts
The headlight and bumper come off in five minutes. Replacing the pump is an easy job for someone who is competent. Make sure you have no recall outstanding for the abs. Your car may have been part of a recall campaign. If it was there will be a black bag over the abs unit.

Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
158 Posts
Just an update for anyone who's interested.
Sorry for the late reply, been a bit busy.

Fitted the ABS pump which I bought on ebay for £30. Seems fine, no more ABS faults. The one I removed had apparently come out of a 2.0 HDI, at least that's what someone had written on it. Mine is a 1.6 petrol. So this car is now on it's third ABS pump, at least.
 

·
Registered
Joined
·
3,426 Posts
my missus 307 abs pump definitely doesnt have a black bag around it

the abs pumps do fail. i had one go on our old ka. our speedo stopped working as well which narrowed it down a bit
 
1 - 17 of 17 Posts
Top