Peugeot Forums banner
1 - 19 of 19 Posts

·
Registered
Joined
·
486 Posts
Discussion Starter · #1 ·
This seems an odd issue. I use apple carplay most of the time with a iphone 6 (iOS 11) in my Allure 3008. Once it connected via cable and working fine and if I put the vehicle to reverse and complete a turn and put back to 'D' the carplay screen does not return. It either show some other screen but pressing any piano button (navigation button or music button or phone button) or carplay icon in the display does not return the carplay screen. But in the background it seems working fine. If a call comes it rings but nothing change in the screen. Only thing is to get the carplay screen back is disconnect the phone from the cable and reconnect. If I remember correct it was like that from the beginning.

Have anyone experienced such thing?. Am I missing something here?
 

·
Registered
Joined
·
408 Posts
Have you installed the latest OS on your iPhone and the latest firmware on your car ?
 

·
Registered
Joined
·
486 Posts
Discussion Starter · #3 · (Edited)
Have you installed the latest OS on your iPhone and the latest firmware on your car ?
I got the vehicle when I have iOS 11 on my iphone. I didn't or intend to do any firmware update by myself but my dealer informed me that it is the latest version of firmware available to my country. Got the vehicle on last month. Also, Tom Tom maps and navigation option not available in my region.
 

·
Registered
Joined
·
1,616 Posts
I have just tried this minus the full turn and the screen returned to the CarPlay screen. Is the full turn an important element in your experience?

Edit

Just tried again and did a full turn of the steering wheel. When I selected 'D', the screen changed to the app screen and a single press of the CarPlay icon brought the app back. Latest firmware and OS.
 

·
Registered
Joined
·
486 Posts
Discussion Starter · #5 ·
I have just tried this minus the full turn and the screen returned to the CarPlay screen. Is the full turn an important element in your experience?

Edit

Just tried again and did a full turn of the steering wheel. When I selected 'D', the screen changed to the app screen and a single press of the CarPlay icon brought the app back. Latest firmware and OS.
Thanks Dautres; I just check with iphone SE having iOS 10.3.3 and no issue works like a charm. But When I plug in my iphone 6 having iOS 11.2 and do a reverse manuring and I cannot get Carplay screen. I does show app screen but even though i Press the carplay icon nothing happens. Following is my testing scenario.

Turn on the engine. once the screen is fully functioning connect the iphone. Turn on music app on my iphone and play my playlist and then runs the maps app on my iphone.

I have to reverse the vehicle first to enter the road from my garage about 20m and have to do a three point turn to start my journey from my home. once i orient the vehicle to driving forward the screen shows app screen but pressing carplay icon nothing happens. but the music app works in the background but can not get into the screen.

what can be the issue.? My system information screens are attached here.
 

Attachments

·
Registered
Joined
·
1,616 Posts
Thanks Dautres; I just check with iphone SE having iOS 10.3.3 and no issue works like a charm. But When I plug in my iphone 6 having iOS 11.2 and do a reverse manuring and I cannot get Carplay screen. I does show app screen but even though i Press the carplay icon nothing happens. Following is my testing scenario.

Turn on the engine. once the screen is fully functioning connect the iphone. Turn on music app on my iphone and play my playlist and then runs the maps app on my iphone.

I have to reverse the vehicle first to enter the road from my garage about 20m and have to do a three point turn to start my journey from my home. once i orient the vehicle to driving forward the screen shows app screen but pressing carplay icon nothing happens. but the music app works in the background but can not get into the screen.

what can be the issue.? My system information screens are attached here.

Hi Jagath, I'm not sure how you got to that screen, I'm sure I've been there before but can't for the life of me remember.

The info screen I go to shows the system and mapping versions in a completely different format.
 

·
Registered
Joined
·
486 Posts
Discussion Starter · #7 ·
Hi Jagath, I'm not sure how you got to that screen, I'm sure I've been there before but can't for the life of me remember.

The info screen I go to shows the system and mapping versions in a completely different format.
For our region mapping is not available and I believe version info is totally different from your one. I access this info in following manner.
- press 'configuration' icon in the upper bar of the digital instrument panel.
- press 'settings' icon
- press 'system configureation'
- select 'system info' tab and press view 'icon'
 

·
Registered
Joined
·
1,616 Posts
I'll have another look in the morning but it may be that a firmware update has remedied what could be a bug in your version, somebody else who has not updated might confirm if they have the same issue as you.

In any event thanks for alerting me to the benefits of CarPlay, I last tried it before uploading some music to my iPhone so I didn't see much use for it. Now I have music files on my phone I have found the perfect way to play my music, far better than a USB stick or android auto.

In addition, BBC iPlayer will allow me to listen to The Navy Lark or the Goons etc. at any time between 12 and 2 to avoid listening to Jeremy Vine, although it probably doesn't mean much to you Jagath. :)
 

·
Registered
Joined
·
486 Posts
Discussion Starter · #9 ·
I'll have another look in the morning but it may be that a firmware update has remedied what could be a bug in your version, somebody else who has not updated might confirm if they have the same issue as you.

In any event thanks for alerting me to the benefits of CarPlay, I last tried it before uploading some music to my iPhone so I didn't see much use for it. Now I have music files on my phone I have found the perfect way to play my music, far better than a USB stick or android auto.

In addition, BBC iPlayer will allow me to listen to The Navy Lark or the Goons etc. at any time between 12 and 2 to avoid listening to Jeremy Vine, although it probably doesn't mean much to you Jagath. :)
thanks. Try to replicate my scenario and check any issue. I will ask my dealer to update the software if available.

Yep. Once you get used to CarPlay you cannot avoid. It is more practical and useful. Personally it better than Android Auto with my experience. Sound quality is much better in apple music than .mp3. This is clearly noticeable with Focal audio.
 

·
Registered
Joined
·
1,616 Posts
thanks. Try to replicate my scenario and check any issue. I will ask my dealer to update the software if available.

Yep. Once you get used to CarPlay you cannot avoid. It is more practical and useful. Personally it better than Android Auto with my experience. Sound quality is much better in apple music than .mp3. This is clearly noticeable with Focal audio.
Sorry jagath, I can't find any screen like yours on my car so I am unable to let you know how my information compares. I've been for a drive to visit family this morning with CarPlay music on for listening to an album. When I returned to the car (phone was left in car) and selected CarPlay, all I had was a blank screen and unplugging the phone rectified this. When I arrived at home I switched off and on again a couple of times but this time the CarPlay screen was still active……… If I were you I would insist that your dealer updates the firmware and direct them to the Spanish site (see Beards’ Thread) for the necessary files. Sorry I can’t be of any more help.
 

·
Registered
Joined
·
15 Posts
Hi there jagath, I am also experience the same exact problem you have with Apple Carplay although the complete turn has nothing to do with the problem (at least in my experience).

Unfortunately you and I are the only ones who have experience this issue so far, most likely due to the software been used in our 3008 (that are completely different version from almost all 3008 around the word *it seems*) mine doesn't have TomTom maps either, I live in Dominican Republic and it's impossible for us to have that feature.

Regarding our problem, I haven't found a workaround for this problem. I think our only option is to update the software with the dealer since our software can't be find on the internet or any peugeot page like the rest of the world.
 

Attachments

·
Registered
Joined
·
486 Posts
Discussion Starter · #12 ·
Hi there jagath, I am also experience the same exact problem you have with Apple Carplay although the complete turn has nothing to do with the problem (at least in my experience).

Unfortunately you and I are the only ones who have experience this issue so far, most likely due to the software been used in our 3008 (that are completely different version from almost all 3008 around the word *it seems*) mine doesn't have TomTom maps either, I live in Dominican Republic and it's impossible for us to have that feature.

Regarding our problem, I haven't found a workaround for this problem. I think our only option is to update the software with the dealer since our software can't be find on the internet or any peugeot page like the rest of the world.
welcome to the forum jorgesalcedo. Your software version and my software version is exactly the same. I also believe issue is related to the software. It is always a issue when i put the vehicle into reverse and back to drive mode ignore full turn thing. In my region also there is no 'Tom-Tom' maps. I have to go to the dealer for first check up in few weeks and I will ask them to check it. If you get any info on this from the dealer please let me know.

Until proper software update and correct the issue the only option would be disconnect and reconnect the cable. Use of 'Magnetic Lighting Cable' is the best way to go.
 

·
Registered
Joined
·
15 Posts
[problem solved]

Hi again jagath2005uk,

So I went to my dealer explainig the problem I had with carplay, at first I show them what was happening (put car in reverse then park, carplay would still sound but it can't be seen on main display no matter what) we tried like 4 times and the 4 times went wrong. So I suggest we take another similar car but newer than mine or recently imported to see if the problem was the same and as expected there was no problen at all (the carplay was still there after putting the car in D or P), so we cheked the version installed in that 3008 and it says "Version 073".

After that was pretty clear that the version 072 (installed in our 3008 did have a problem) so they proceed to install the new update, I waited around an hour and the update was succesfully installed, to my surprise I even got a newer version (074), the problem got away and everything is perfect now.

Since our 3008 are exactly the same you should ask for the lastest version in order for the problem to be solved.

Hope this help. please let me know if there's anything I can do to help you with this issue.
 

·
Registered
Joined
·
486 Posts
Discussion Starter · #14 ·
Hi again jagath2005uk,



So I went to my dealer explainig the problem I had with carplay, at first I show them what was happening (put car in reverse then park, carplay would still sound but it can't be seen on main display no matter what) we tried like 4 times and the 4 times went wrong. So I suggest we take another similar car but newer than mine or recently imported to see if the problem was the same and as expected there was no problen at all (the carplay was still there after putting the car in D or P), so we cheked the version installed in that 3008 and it says "Version 073".



After that was pretty clear that the version 072 (installed in our 3008 did have a problem) so they proceed to install the new update, I waited around an hour and the update was succesfully installed, to my surprise I even got a newer version (074), the problem got away and everything is perfect now.



Since our 3008 are exactly the same you should ask for the lastest version in order for the problem to be solved.



Hope this help. please let me know if there's anything I can do to help you with this issue.


Thank you very much for the update. I also went to the dealer and showed the issue. The dealer told me he will check back and will come back to me and haven’t respond yet. I will call them again.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
408 Posts
What has been upgraded precisely ?
And this version 074, where do you see it please ?
 

·
Registered
Joined
·
486 Posts
Discussion Starter · #16 ·
[Issue Resolved]

Hi jorgesalcedo, This is my update on the issue. Today afternoon I did my update too version no. 74C. The carplay issue was resolved similar to you.

one other i notice after update is now in the 'CarPlay' mode when I press the 'Telephone' piano button nothing would happen. Before update in the carplay mode if I press the same button it open the phone window. Now it works only in bluetooth mode.

I do not know other regions how it behave, jorgesalcedo, if you have found new things after update let me know. Thanks.
 

·
Registered
Joined
·
15 Posts
I’m glad to hear you got the update! In relation to the piano phone button, my experience has not changed. However let me explain how it has always work for me.

Let’s say i’m on the A/C window, if I press the phone piano button the screen goes back to carplay where it was left the last time (it doesn’t take me to the phone app on my carplay)

Scenario 2: i’m on A/C window, if I press the phone button on the steering wheel it DOES take me to phone app on Carplay.

In short words,

Phone button on steering = open phone app on carplay

Phone piano button = open carplay where it was left last time used.

You can try it out and let me know!

Thanks
 

·
Registered
Joined
·
486 Posts
Discussion Starter · #18 ·
I’m glad to hear you got the update! In relation to the piano phone button, my experience has not changed. However let me explain how it has always work for me.

Let’s say i’m on the A/C window, if I press the phone piano button the screen goes back to carplay where it was left the last time (it doesn’t take me to the phone app on my carplay)

Scenario 2: i’m on A/C window, if I press the phone button on the steering wheel it DOES take me to phone app on Carplay.

In short words,

Phone button on steering = open phone app on carplay

Phone piano button = open carplay where it was left last time used.

You can try it out and let me know!

Thanks
Thanks jorgesalcedo, checked it and can confirm after update it is same for me however, before update when I pressed the phone piano button it went to the CarPlay phone screen. I used this function number of times and now it is work only with steering phone button. Anyway, that is good enough and really glad that the main issue is resolved now.
 

·
Registered
Joined
·
17 Posts
I also have an issue with CarPlay using iPhone SE. If I am playing music from my phone via cable, there does not seem to be a way to get back to the main CarPlay screen to change to a podcast. I should mention I have Waze on in the background on audio to get me around traffic.
 
1 - 19 of 19 Posts
Top