Peugeot Forums banner

1 - 19 of 19 Posts

·
Registered
Joined
·
60 Posts
Discussion Starter #1
Hi all,

New here and first post so bear with me :)

Car: Peugeot 307 XS 2.0 estate 2004.

A few days ago while driving all instruments stopped working (speedo, rpm, fuel etc) while at the same time the STOP light and fuel empty light started flashing (I had a full tank at the time).

After 20-30 seconds it stopped and all instruments returned to normal.
This has however happened quite a few times over the last few days.

I have now had a beeping sound a few time's too at the same time as the above problem...

I wondered if anyone has had this problem or know's what it might be before I take it to a garage? Or if there might be a way to fix the problem myself (probably not I know)

Anyway, any info or advice would be great!

Cheers
Eddie
 

·
Registered
Joined
·
60 Posts
Discussion Starter #3
I've been googling a bit and i'll try a rest of the BSI and see if that helps, hope I don't have to take it to a garage as its probably gonna cost a bomb...
 
S

·
Guest
Joined
·
0 Posts
I dont know if planet will diagnose a dodgy earth strap,

But its always worth finding the nearest member with planet to get a diag done, just to be safe

Where are you located?
 

·
Registered
Joined
·
60 Posts
Discussion Starter #5
I would love help checking it, I am located in Stockholm in Sweden though so may be a problem finding someone :)

(i'm from Leicester though)

Cheers
 

·
Registered
Joined
·
60 Posts
Discussion Starter #6
Well, very strangely the problem seems to have stopped (the last two times i've driven the car anyway)

I was wondering though... I have now a copy of Planet that I was thinking of using to have a look and see what error code there might be. I need to buy a cable however to connect the car to my laptop.

Does anyone know if a ELM 327 OBDII cable would work with Planet? Some software comes with the cable but I think it may be better to use planet?

Here's the info I have on the cable I was looking at.

OBD-II protokoll:
- ISO15765-4 (CAN) - ISO14230-4 (KWP2000) - ISO9141-2 - J1850 VPW - J1850 PWM.

I have a feeling I will have to pay quite a bit for a garage to have a look for me..

Any help would be great!

Cheers
 

·
Moderator
Joined
·
11,992 Posts
No, it has to be the Planet. Its more than just a cable, it has a box of electronic trickery in it.

A fellow member will do a diag for the cost of a beer upto a tenner.

A garage will do a generic code read for about £20, but that won't necessarily interrogate and test individual components like Planet will.

Peugeot dealers do a Planet diag for either £40 or £70.

The Planet software is about £65 from door2doorshop.com or £100 upwards on Fleabay.
 

·
Registered
Joined
·
60 Posts
Discussion Starter #9
haha, yeah, I may have trouble finding someone close by... :)

As I said though, the problem seems to have stopped,but.. i'm starting to think it may have been something to do with the immobilizer maybe. I vaguely remember using a different key for the first time (wanted to see if it had a better battery than the one I normally use)

I have noticed that the red light on the door lock button has been lit all the time. Its off now however and my problem seems to have gone away for the moment. Wonder if maybe I need to re-program that other key...

The local Peugeot garage quoted me the equivalent of 150 quid for a error code read (Sweden's not the cheapest country) so looks like i'll buy a cable and program to check the error codes just to be safe, we have new baby so I don't want the car breaking down in the middle of nowhere!

Cheers :)
 

·
Registered
Joined
·
30 Posts
J

·
Guest
Joined
·
0 Posts
Yes thats the one.... look at cost of postage though.... cost me £30 postage to UK :nod:
 
J

·
Guest
Joined
·
0 Posts
Nope, definitely won't work with Win7..... will only ever always work with XP :nod:

I believe DiagBox, the new version of PP & Lexia, will work with Win7
 

·
Registered
Joined
·
1,912 Posts
jmkent our diagnostic is win7 and gives the choice of peugeot or citroen marques on startup and planet or diagbox further in. But our 407 will only run on diagbox and our307 on planet. I cant fathom this but we do have planet on virtual machine win xp, if it is switching to xp from win7 i dont know. Greater minds have enabled my laptop, i can barely work it all.
 

·
Registered
Joined
·
1,912 Posts
mm I see what you saying, you may well be right jmkent, Ive just had a nasty surprise with diagnostic, it had thrown up throttle position sensor a week ago and finding the time I went to clear it to see if it would come back; when i checked, it had gone, to be replaced with p0422. Now im sorry i looked. Its cat maybe killed by overfuelled turbo I believe, i will definitely clear this to see what happens. Do we do ourselves any favours by looking? Incidentally I am on win7 enterprise
 

·
Registered
Joined
·
1,912 Posts
just to say P0422 hasn't returned jmkent. I think its because PO483 hasn't been resolved yet. Still waiting on warranty issues to be sorted for that
 
1 - 19 of 19 Posts
Top