Peugeot Forums banner

1 - 20 of 21 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
Hi I have 308 1.6 hdi year 2007.
I am installing pke into it. So far I have managed to install push start button and am now trying to add pke feature. Can anybody tell me does this car have unlocking positive trigger, negative trigger or positive/negative trigger. I have inspected lock/unlock button on main console and it only has one wire which is used for both lock/unlock and am unsure of it - it is 0v when unlocked and fluctuating + when locked (when probing with positive end of multimeter). Also, if anyone knows the location of central locking unit it would be much appreciated.
Furthermore, I need to locate fuel gauge wire, direction lights wires and handbrake wire.
Many thanks 4 any help...
 

·
Registered
Joined
·
13 Posts
Discussion Starter #2
lock wire

I have managed to locate lock and unlock wires in main door. Unlock wire triggers simply by grounding it but I am unable to trigger lock wire no matter what I try. Any help would be much appreciated.
 

·
Registered
Joined
·
5,916 Posts
Never stripped a Peugeot lock but I have stripped similar locks and they used a simple dc motor for locking the doors. They simply reversed the polarity of each of the two wires and used microswitches as limit switches for each direction. The lock / unlock button just sends a signal to an ECU (probably the BSI) telling it to set the door locks opposite to their current status, it doesn't actually connct to the lock mechanisms themselves.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #4
Thank you very much for this. It is exactly so. I have managed to locate both lock and unlock wires at bsi. But I still have the problem of triggering lock wire. When I connect my unlock trigger wire (from pke system, it is negative) to main console lock/unlock wire (which is positive and triggering when given negative signal) than my lock wire is being triggered with lock trigger wire (from pke) but with delay - first dome light turns on and than it locks. The problem of that connection is that it doesn't auto lock when distancing from vehicle. When my unlock wire is properly connected to unlock wire on bsi, lock wire doesn‘t work at all. Maybe you have some idea on how to set this up. I have relays and diodes at disposal. Many thanks either way
 

·
Registered
Joined
·
96 Posts
Is this a universal item you are installing?

If so, then you will have a few issues if your car is ever stolen:

Your insurance will be void as you have left a immobiliser unit inside the car
Your insurance will be void as you have left a key in the ignition?


How are you doing the push botton start to release the steering lock? I assume you are either breaking the steering lock or leaving ahalf cut key in ignition?

How are you dealing with immobiliser if using an aftermarket PKE system? Again are you hiding the transponder in the car somewhere?
 

·
Registered
Joined
·
96 Posts
87a type relay uses the normally closed contact from the relay.

In your diagram, when no buttons are pressed, you are constantly sending 12v to the unlock trigger output from PKE and also constant 12v to the unlock wire for the car, therefore I think when nothing is pressed, you are energising the unlock wire from the car and at the same time , grounding the lock wire!

I think the lock ECU will go crazy and freeze until the issue is removed?

Can you confirm:

1) On the BSI, you have 2 inputs to BSI : 1 for locking and 1 for unlocking? In normal unlocked position, can you check the voltage at these inputs and see what they are at? Then check the same for when car is locked, and see what they are at?

2) On the BSI, check what you have to do to the 2 inputs to lock the car first and then what you have to do to unlock?

3) on your PKE, what do you have for the outputs from the system when locked is pressed and when unlocked is pressed? What is the output from the system when nothing is pressed?
 

·
Registered
Joined
·
13 Posts
Discussion Starter #8
My bad 87 instead of 87a.
1)unlocked:
lock wire: 2.6 when probed with black probe, red on +12V, 9.3 when probed with red, black on ground;
unlock wire: 12.5 when probed with black,, red on +12V, 0 when probed with red, black on ground.

locked:
lock wire: 12.4 when probed with black, red on +12V, 0 when probed with red, black on ground;
unlock wire: 2.6 when probed with black, 9.3 when probed with red.

2) To unlock I only need to ground unlock wire, I dont know what to do to trigger lock wire.

3) Both lock and unlock triggers on pke are -500 mA
 

·
Registered
Joined
·
96 Posts
ok, so i read it as: ( Car is DC, so only applies to when black is on ground and red is doing the probing):

When car is unlocked ( it has been unlocked and it is sitting in the unlocked position):
Lock wire is high ( 12v) : you only seeing 9.3 v perhaps becuase your battery is giving you 9.3v at the moment as the car is not running.
Unlock is low ( 0 v)

When car is locked ( it is siting in the locked position):
Lock wire is low (0v)
Unlock wire is High ( 12v).

To unlock the car from locked position: Ground the unlock wire and it unlocks the car

To lock the car: You can't get it to lock at the moment : What would happen if you ground the lock wire. Does it not lock the car? You can only do this when car is unlocked.

if that doesn't work to lock the car, then get someone else to stand outside the car with you inside with your probe on the lock wire. You should be seeing 12v. Get your friend to lock the car with the key and you watch the probe and see what happens to the voltage? Does it go to 0v and stay there, or does it pulsate to 0 and then back up to 12v ( or 9.3v).

Do the same test, this time with your probe on the unlock wire. When car is unlocked, you should be seeing 0v on this probe. get your friend to lock the car and see what happens to the probe. Does it go up to 12v and stays there ( as I would expect ) or does it pulsate to 12v and then drops back down to 0v?

My guess is that you need 2 inputs to the BSI for this: High input ( 12V) and low input ( 0v or ground). YOu need them both to be able to lock and unlock the car. And they have to stay at that level for the duration. So if your pki is only giving you a short signal and then drops to 0v once button is released, then what you might need is something called 'latching relay' and not a normal automotive relay.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #11
It doesn't fluctoate, lock wire is 12 when unlocked and 0 when locked (probed with red), unlock wire is 0 when unlocked and 12 when locked. I have tried both methods posted above and they don't work. I am unable to trigger lock wire.
 

·
Registered
Joined
·
5,916 Posts
Sounds like you need a 2 pole changeover relay which flips each wire when energised.

It also sounds to me like there isn't a lock & unlock wire but two wires feeding a motor. One wire will be switched to positive with the other wire being grounded when locking and the opposite way when unlocking.

Can you post the PKE wiring instructions and / or diagram. I think the idea of a seperate lock & unlock wire is a red herring - it may be the pke is outputting +12v on wire 1 and grounding wire 2 when locking and then grounding wire 1 while switchin wire 2 to positive when unlocking.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #13
Ok I have figured out how to trigger lock wire. It triggers by cutting unlock wire and than grounding it(sending negative signal from pke lock wire). Unlock triggers by grounding bsi end of unlock wire. The problem with that connection is that when opening door it auto locks so there is a problem of leaving the key in the car. Also it messes up dome light cause it auto shuts down when opening door. So I tried connecting relay which disconnects unlock wire when locking car. For some reason positive end of relay bothers lock signal so it doesn't work. Than I used steering light signal(which is positive) to disconect unlock wire when locking. And it seemed to work. Car locked when moved away and unlocked when approached; also, blinkers worked as well(sometimes, sometimes not) But, for some reason, when I press lock on remote it locks and right away unlocks. I could live with that since when I press unlock signal it auto locks after few seconds. But when I start engine, shut it down and move away it does lock/unlock thing (sometimes it doesn't but mostly does). I am busting my brains out trying to figure it out. Also, I believe I have wrongly connected trigger door wire - I connected it to one of dome light wires(dome is with delayed light) which is always positive - originally I connected it to dome light wire which is 0 when light off and +12 when on but that was making clicking sound from pke unit with light off...
Any ideas?
 

·
Registered
Joined
·
13 Posts
Discussion Starter #16
I connected unlock wire through relay to lock trigger so that it opens it when triggered. Also unlock trigger to bsi end of it. Than I used steering light, which is positive and changed its polarity with relay and than connected it to triger lock wire.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #19
Steering light, I have 2 pke steering light triggers, they trigger when locking or unlocking. I took one of those, converted its polarity and used as much needed lock signal(my lock trigger wire was occupied opening unlock wire).
 
1 - 20 of 21 Posts
Top