Peugeot Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
Recently many of you noticed that I've been reporting a lot of random issues with the car. Starting from the engine not having any power to even the damn alarm remote.
While driving down an alley, not more than 30 km/h, close to my local alarm garage, something snapped underneath the bonnet and made noise louder than a gun shot.
Went to take the next stop to open it up, found out that on bottom left side of the engine, where the belt is, was shit ton of leakage and some black string holding on the bosch pump.
When you turn the car on, sounds like the engine doesn't have oil, but it does, so can't figure out where the sound is coming from.
Underneath the pump I see something that doesn't look like the cars belt, but holds completely loose and keeps hitting the belt for no reason, as far as I'm concerned.
It sounds like the car's gonna explode within the next few seconds, that's how bad the "little foot on the gas paddle" sounds. I hope it ain't the belt, it seemed fine, had both belts changed less than a month ago.
Anyone possibly have any ideas what on this so called "earth" is going on with my damn car. I'm sick of driving this thing to the local garage every 50 miles I take.
 

·
Registered
Joined
·
1,805 Posts
Can you take pics of the pump? Can you identify where the leak is specifically?

Can you see the tensioners/pulleys on the engine? If so are they all present and correct?

Is the thing that hits the belt the black plastic belt cover?

Or is it a seal/gasket of some sort?
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #3 ·
The leak comes from the passenger side, left front tire. Like shown here:

The belt is oiled up like almost the rest of the car:



Took the plastic cover off, engine seems to be fine, top of the pump too.


Yet oil squirt everywhere, even on the bonnet, here's a few pics atleast of what I might thought looks suspicious, especially this belt on the left side of the engine, the belt is intact, yet there's some black string that's everywhere, on the metal sheets on the covers, I can't seem to figure out what's it for.





Here's the whole package:

Imgur: The most awesome images on the Internet
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #4 ·
Well I figured out half of the problem. The pump leaks on front and back, squirting on the belt that's on the left side (belt used for charging the accumulator/battery). It snapped on one side causing the terrible noise. The cost for the fix is actually really high considering the pump is long gone... Around 400 euros in total... Better fix the original than buy a new one, who knows what the quality might be, then again... this one is completely broken, not sure what to say anymore. One thing is certain, this car was seriously destroyed by the previous owners.
 
1 - 7 of 7 Posts
Top