Peugeot Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hi there. I am aware that the thread on the Pollution fault has been closed but I wanted to add that I have had the depollution system fault warning come on may times and the fan revs up and motor would run very rough like on 3 cylinders and I would unplug the ignition coils 1 by 1 to find the dead one and replace it then all was ok for months till it happened again. My 2006 407 V6 now has all coils replaced and I found only genuine parts lasted. Now I have noticed that when I put it in Sport mode or just basically gunn it it seems to lose power around mid range? could this be the fap filter? car runs fine otherwise. any help would be much appreciated.
 

·
Registered
Joined
·
4,784 Posts
Hi there. I am aware that the thread on the Pollution fault has been closed but I wanted to add that I have had the depollution system fault warning come on may times and the fan revs up and motor would run very rough like on 3 cylinders and I would unplug the ignition coils 1 by 1 to find the dead one and replace it then all was ok for months till it happened again. My 2006 407 V6 now has all coils replaced and I found only genuine parts lasted. Now I have noticed that when I put it in Sport mode or just basically gunn it it seems to lose power around mid range? could this be the fap filter? car runs fine otherwise. any help would be much appreciated.
petrols do not have fap
when was car last serviced ie spark plugs changed
have you had it on planet/diagbox
 
1 - 3 of 3 Posts
Top