Peugeot Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
99 Posts
Discussion Starter #1
Getting so close to ditching this 307 now :(

Just had clutch replaced but now have another new issue!

Basically when I first start the car (1.4HDi) it throws out quite a bit of strong smelling white smoke. Seems to be fine from then on though.

But also when sitting idle the car seems to shake quite a bit. I know it's not the engine mounts as they have all been checked over.

Any ideas??
 

·
Registered
Joined
·
99 Posts
Discussion Starter #4
Water levels seem fine, no noticeable loss at all.
Could it be anything to do with the injectors?

It all seemed to start when I ran the car very low on fuel, think it must have been running on fumes, so could an injector have been damaged/blocked by some gunk at bottom of fuel tank?
 

·
Registered
Joined
·
99 Posts
Discussion Starter #7
but sadly white is also uncombusted diesel. Which could mean injectors or compression/valve timing.
I may go for a simple fuel filter change and some redex (or any other suggestions?)

And if still bad then see about fitting new injectors. Need to get me some pig planet testing first I think!
 

·
Registered
Joined
·
99 Posts
Discussion Starter #10
Mine sounds fine, a slight ticking noise at certain revs but I'm ignoring that one for now!!

Only get white smoke when starting the car and the shaking is only sometimes.. Haven't noticed it for a couple of days now actually

Still smoke at start up though
 
1 - 10 of 10 Posts
Top