Peugeot Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
108 Posts
Discussion Starter #1
307 1.4hdi

144,000 miles

2003 reg

hi

my turbo seems to work sometimes and not others , my exhaust was blocked by the honeycomb from the cat , it was like this before i bought it and i have no idea how long it was driven around like that but i have read that if exhaust blocked it can damage turbo

is there anyway i can check the turbo or does it need testing at a garage

thank you
 

·
Registered
Joined
·
238 Posts
if it's working at times and not others it could be the vacuum solenoid or a split vac pipe, or could be the actuator on the turbo itself. check the solenoid and pipes first.
 

·
Registered
Joined
·
556 Posts
I'd undo the hose going to it and check it for excessive play and oil etc, usually they are noisy when worn, you could give the egr and manifold a good clean out. If it was starved of oil I'd expect the bearing to be very rough i think you'd know if it was bad, you can check the engine oil for metal swarf.
I bought the mrs 307 with a failed turbo, the seal had gone and it dumped the oil into the exhaust which blew smoke all over the place i had to replace the turbo and the back box to fix it.
 

·
Registered
Joined
·
108 Posts
Discussion Starter #4
i have had a new solenoid fitted and no difference , the car has been remapped and when it was tested after the bloke who did remap said something wasnt right as if the actuator was sticking . is there anyway i can check this ? and can it be replaced if faulty ?
 

·
Registered
Joined
·
26 Posts

·
Registered
Joined
·
238 Posts
i have never done a turbo on a pug. after having the engine out and looking at it from below i can tell you it's not a easy job with the engine in the car. someone else on here might have more experience on removing the turbo with the engine in. good luck
 

·
Registered
Joined
·
556 Posts
Right on the mrs 307 i was told the engine was fooked so i started taking it out and got to the point of pulling it forward as it is leaning back when in anyway i took the turbo pipe off and that's when i saw it was knackered so i got a new 1 and put it all back together but i definitely remember thinking there is no way i could have got the turbo off without undoing the engine! It is probably possible but i think it would be a bitch of a job without undoing the engine to pull it forward.
Her engine has the turbo at the back (engine code RHY) i think.
 

·
Registered
Joined
·
26 Posts
i have never done a turbo on a pug. after having the engine out and looking at it from below i can tell you it's not a easy job with the engine in the car. someone else on here might have more experience on removing the turbo with the engine in. good luck
Thanks but feel I need more than luck. I couldn't get anywhere near it. Not without removing trim etc & it was just off for a week when blanking egr ( still wetting the bed over that ordeal) Do you buddy, or anybody for that matter have an idiots guide of photo's regarding where & what I need to check? As all these solenoids & sensors seem to look different on each picture I look at.. And in different positions. I did remove a tiny plastic coupling,with 2 tiny hoses attached, which connected to a brass looking pin which was attached to approx 3 inch circular cover ( just below the air intake elbow). When I removed it there was a tiny hiss?? I haven't a clue what that meant!! Sorry to appear a fully fledged shoulder muncher but this is the first car I've ever tried to understand as the most advanced I achieved beforehand is changing the oil.:help:
 

·
Registered
Joined
·
34 Posts
Hello Mr Bandit. I am in similar shoes to you. So far I have found a few intresting posts on the matter. You can check oil flow by removing oil return pipe from sump side and running engine for 60 secs at idle. Should get about 30cl. Apart from that I am waiting for replies to your post for further testing. :)
 

·
Registered
Joined
·
209 Posts
Thanks but feel I need more than luck. I couldn't get anywhere near it. Not without removing trim etc & it was just off for a week when blanking egr ( still wetting the bed over that ordeal) Do you buddy, or anybody for that matter have an idiots guide of photo's regarding where & what I need to check? As all these solenoids & sensors seem to look different on each picture I look at.. And in different positions. I did remove a tiny plastic coupling,with 2 tiny hoses attached, which connected to a brass looking pin which was attached to approx 3 inch circular cover ( just below the air intake elbow). When I removed it there was a tiny hiss?? I haven't a clue what that meant!! Sorry to appear a fully fledged shoulder muncher but this is the first car I've ever tried to understand as the most advanced I achieved beforehand is changing the oil.:help:
did you manage to get to the EGR without removing the exhaust, Haynes qotes it as one hell of a job!
 
1 - 11 of 11 Posts
Top