Peugeot Forums banner

1 - 20 of 21 Posts

·
Registered
Joined
·
183 Posts
Discussion Starter #1 (Edited)
Hi when I drive along in my 407 2.0 HDI 05 it kinda holds back then goes again continually, but only when the throttle pedal is slightly pressed. to avoid it happening I have to keep changing throttle position only thing I know is DPF fluid needs topping up and a regeneration doing it's sounds a bit cranky on cold start up and seems like a theres a missfire but only for about 5-10 seconds. I have changed oil filter and airfilter and have the DPF fluid just need some decent weather to do it
 

·
Registered
Joined
·
394 Posts
Lots of info around on this, see the 2.0 HDi regen thread below for a bit more.

Double check it's not the air doser. Common fault, the flap that shuts the intercooler off breaks or gets stuck :thumb:
 

·
Registered
Joined
·
183 Posts
Discussion Starter #5
Lots of info around on this, see the 2.0 HDi regen thread below for a bit more.

Double check it's not the air doser. Common fault, the flap that shuts the intercooler off breaks or gets stuck :thumb:
not sure were that is
 

·
Registered
Joined
·
394 Posts

·
Registered
Joined
·
183 Posts
Discussion Starter #7
Not sure where what is?

He air doser is this thing at the top of the engine CITROEN/PEUGEOT/ 2.0 16V HDI RHR THROTTLE BODY/AIR DOSER 9646846380 / 2004-2010 | eBay

Take it of and clean it, if either of the 2 butterfly flaps are stuck or broken then you have gut. culprit.

The other regen thread is here http://www.peugeotforums.com/forums/407-41/2-0-hdi-regen-75329/ plenty more where that came from if you do a search :thumb:
much appreciated, will do that. thinking about blanking EGR now reading on here about it hope that will fix it. thanks
 

·
Registered
Joined
·
183 Posts
Discussion Starter #9 (Edited)
Not sure where what is?

He air doser is this thing at the top of the engine CITROEN/PEUGEOT/ 2.0 16V HDI RHR THROTTLE BODY/AIR DOSER 9646846380 / 2004-2010 | eBay

Take it of and clean it, if either of the 2 butterfly flaps are stuck or broken then you have gut. culprit.

The other regen thread is here http://www.peugeotforums.com/forums/407-41/2-0-hdi-regen-75329/ plenty more where that came from if you do a search :thumb:
hi before removal I had fault codes P1435 and P0238 and saying on screen on dash de-pollution system faulty, so I removed throttle body and gave a good cleaning had loads of crap in there, also noticed that the metal flap was a bit sticky this took some cleaning but still has a slight stick on it can't see why it's still slightly sticking as it looks spotless now anyhow I put everything back together and started the car. I noticed that I still have a noisy crank sound and missfire when cold so no difference there. I then proceeded to remove turbo sensor and gave a blow in pipes and could here something happening inside so gave it a clean up and replaced. I reset fault codes and only P1435 returned but this time took a little longer for engine light to come back on.
de-pollution system faulty returned to dash screen.Should I remove that shiny metal EGR pipe also to give that a clean I don't want to blank it off not yet anyway I would rather it be as it should. Anything else that could be causing this? what about crank sensor?:confused:
 
C

·
Guest
Joined
·
0 Posts
Why not blank it or disconnect wiring just to prove it's egr or not?

Mines blanked and has been for 18+ months and thousands of miles with no ill effect just improved drive.
 

·
Registered
Joined
·
183 Posts
Discussion Starter #11
Why not blank it or disconnect wiring just to prove it's egr or not?

Mines blanked and has been for 18+ months and thousands of miles with no ill effect just improved drive.
Can you tell me were the plug is i need to disconnect photo if poss thanks
 
C

·
Guest
Joined
·
0 Posts
Follow that silver pipe your on about cleaning from front of engine to the back as it's attached to egr to the right of the pipe on the egr is the wiring plug just disconnect it. Make sure you do it when engine isn't running, engine man light will come on but when reconnected it will eventually turn off.
 

·
Registered
Joined
·
394 Posts
Yep, if you take the silver pipe off, clean it out and I'd blank the egr off anyway, mine is blanked. Not sure what P1345 relates to off the top of my head, so can't help on that one. My air doser was carbon'd up and the car did something similar, it was ok for a bit but had its time if the month on Thursday so need to keep an eye on it lol
 
C

·
Guest
Joined
·
0 Posts
This is what little I could quickly find on P1345

P1345 SGC (cam position) sensor circuit Malfunction / Crankshaft
 

·
Registered
Joined
·
183 Posts
Discussion Starter #15
Why not blank it or disconnect wiring just to prove it's egr or not?

Mines blanked and has been for 18+ months and thousands of miles with no ill effect just improved drive.
Thanks for that but Why fit them in the first place if you dont need them
 

·
Registered
Joined
·
183 Posts
Discussion Starter #16
This is what little I could quickly find on P1345

P1345 SGC (cam position) sensor circuit Malfunction / Crankshaft
Removed plug from EGR took it for a short spin seems bit better its not coughing now when you stay at a steady pace unfortunately i didnt test drive after cleaning that other part earlier will try that tomorrow any idea were that cam or crank sensor is located
 

·
Registered
Joined
·
183 Posts
Discussion Starter #18
Yep, if you take the silver pipe off, clean it out and I'd blank the egr off anyway, mine is blanked. Not sure what P1345 relates to off the top of my head, so can't help on that one. My air doser was carbon'd up and the car did something similar, it was ok for a bit but had its time if the month on Thursday so need to keep an eye on it lol
I have put a 90ml shot of redex in tank its only quarter full though just gonna run it like that and put some more fuel in in about 30 miles
 
1 - 20 of 21 Posts
Top