Peugeot Forums banner

1 - 20 of 25 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1 (Edited)
Hi everyone

I have a 307hdi 2.0 90 diesel

I had to get high presure fuel pump changed as it was leaking and causing problems, anyway had it changed and now car wont start at all. Put old pump bk in and its fine but oviously still with problems. old and new pumps are siemens and mechanic says the old pump spindle thingy spins fine but new pump it doesnt as has friction.

any ideas?
 

·
Registered
Joined
·
14,266 Posts
The obvious idea is the replacement is faulty but he may have not primed it fully they take a lot of priming to get them full before they will fire but if he managed to get the old one working again then seems unlikely.

I would try a different pump.
 

·
Moderator
Joined
·
5,633 Posts
Where the pumps identical and you have not fitted Bosch instead of Siemens so no lp pump to lift fuel

Sent from my SM-G900FD using Tapatalk
 

·
Registered
Joined
·
14,266 Posts
BOLLOX pumps do NOT need calibrating coding or any other sort of trickery they are simply pumps they take fuel in they throw fuel out the control is all done by the ecu

Some vehicles have coded pumps peugeots do not.
 

·
Registered
Joined
·
14,266 Posts
More you say more it sounds like replacement pump is the problem if the pump is full of fuel then spinning the drive side should throw fuel out the outlet even if the pump is in your hand !
 

·
Registered
Joined
·
13 Posts
Discussion Starter #10
is the drive side the spinny bit? if so its very hard to spin giving alot of resistance... old one thats leaking spins easy ( maybe thats y its leaking? )
 

·
Registered
Joined
·
13 Posts
Discussion Starter #12
The pressure sensor does come out white plug. The stop solenoid orange plug is pressed in.( what i been told)

Is the stop thing meant to stay pressed in?
 

·
Registered
Joined
·
14,266 Posts
There is NO stop solenoid modern common rail engines are ecu controlled no need for a stop solenoid sounds like your mechanic is not as clued up as he needs to be !!

Did YOU see it working in previous car ?
 

·
Registered
Joined
·
13 Posts
Discussion Starter #14
Yes car was running fine.
mechanic has never done it on a 2.0hdi. he done it on a 1.6 and it was straight forward.
 

·
Registered
Joined
·
14,266 Posts
2 LITRE much easier than 1.6 !!

NO IDEA WHAT SOFTWARE YOU ARE BEING TOLD YOU NEED BUT YOU DONT :)

NO coding NO programming NO SOFTWARE needed its plug and play IF its the same type i have swapped loads as i have a siemens 406 here i use for testing purposes !
 

·
Registered
Joined
·
4,777 Posts
I def feel utterly confused, this is the pump on car.

The guy i got pump off n my mechanic say it needs programming. I have no idea. Ill prob end up soending a fortune end of month for brandnew one :(
the guy you got the pump off and your mechanic are wrong, them pump is faulty end of
 

·
Registered
Joined
·
14,266 Posts
Try ANOTHER pump as something is not right dont waste time or money trying to program something that CANNOT be programmed.

Im not even sure of what your real problem is you may not even need a pump for all we know !!

WHY WONT YOU LISTEN !!
 
1 - 20 of 25 Posts
Top