Peugeot Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
So I noticed my right hand high beam was a bit .... misaligned. I thought maybe it just needed reseating, so managed to get the cap off and found ... no retaining clip. Bugger. I pulled off the left hand one to have a look, and to my eye (or at least, my camera´s eye) it appears that some part of the support for the clip may be missing.

It was all I could do to fit the lens of a smartphone camera into the incredibly tight space - but I managed, and I have attached the two photos I obtained, in the hope someone can identify what, exactly, is missing ... and where I can get another one!!

(Please don´t say "buy another complete unit" .... not for the want of a clip, no)
 

Attachments

·
Moderator
Joined
·
5,034 Posts
I took one of my high beam bulbs out once and it took nearly 2 hours to put it back. Clip is a stupid design and I spent about an hour or so trying to put the clip in upside down. Pretty sure you can just buy a new clip on ebay etc

Sent from my K013 using Tapatalk
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
I got a packet of H7 clips from eBay buuuuuuuut .... compared to the Left Hand side, the right hand socket appears to be missing some kind of support or mounting for the clip.

Attached, photo of complete Left Hand High Beam - please excuse lack of detail but .... it's bloody hard to fit a smartphone in there!!
 

Attachments

·
Moderator
Joined
·
5,034 Posts
You UK based ??

Sent from my K013 using Tapatalk
 

·
Moderator
Joined
·
5,034 Posts
Forget last post,I checked your sig lol, maybe join my FB. page and ask on there as I can't see anything amiss

Sent from my K013 using Tapatalk
 

·
Registered
Joined
·
12 Posts
In the second pic of post 1 you show where the clip sits, it just presses into that groove and is held in by friction then rotates down/across to clip onto the bulb
 
1 - 8 of 8 Posts
Top