Peugeot Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi, just joined this forum so hope I've posted in the right place. I've got Tepee Outdoor HDI 2013 and the central display has gone from showing how many miles left in the tank - to just flashing up random numbers and MPG. I've not touched anything it just started flashing and going doolally when I started the car this morning. Can anyone please tell me how to get it back to normal? Many thanks
 

·
Registered
Joined
·
2,469 Posts
Going doolally is often a sign that the battery volts are low - should be 12.4 or more with the engine off. You may have been doing too many short runs, or the alternator may be inefficient, or the battery may be approaching end-of-life. Give the battery a good charge first, then measure the voltage across the terminals with the engine running - should be at least 13.6V, but over 14V is common when all is well.

Then try rebooting the BSI; see here.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Will check the battery this week - we have only been doing short journeys for a while - so maybe that is the problem. Watch this space :0)

Many thanks for your help - I see you're from Jersey - what a lovely part of the world!
 

·
Moderator
Joined
·
5,891 Posts
Also worth checking you have not pressed button on end of indicator stalk with out noticing and switch to instantaneous MPG etc on trip computer. Pressing end of stalk will cycle through the options one press at a time
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
Thanks for all your help - problem solved - we had touched the stick without knowing it!!

Cheers
 
1 - 5 of 5 Posts
Top