Peugeot Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter #1
my husbands car has had this problem for a good while now where it takes 3 or 4 attempts at getting going she cranks for ages and sometimes drains the battery but once she's fired up she runs great but now its every time you want her to start she just doesnt want to fire up without the aid of easy starting spray into the air filter now I know we should take it to a garage but if im honest we cant afford a great deal so if they say its fuel pump then we'd have to fork out money for that and if its glow plugs we'd have to find the money for that plus labour for all this but if we know whats wrong then my husband can have a go at fitting it himself but we just want to know for certain whats causing the problem any ideas would be much appreciated TIA
 

·
Registered
Joined
·
9,733 Posts
could you tell me what mm the rubber pipe has to be?
Roughly the same as you take off , i can`t mind (its more about the plugs on either end fitting tight than the actual pipe , a bit bigger just means you`ll have too secure with clips), tell him to pull one end off the fuel filter and that`ll give him an idea , maybe ask DavidIreland he might have spec at hand.
 

·
Moderator
Joined
·
11,775 Posts
Hello SJ. I'm originally from Woodhouse! My brother is a Pug lover and on his second 306. He does all his own maintenance and servicing so if your hubby wants local help, he's the guy and is down the road in Attercliffe.
 

·
Registered
Joined
·
26 Posts
Discussion Starter #10
Hello SJ. I'm originally from Woodhouse! My brother is a Pug lover and on his second 306. He does all his own maintenance and servicing so if your hubby wants local help, he's the guy and is down the road in Attercliffe.
any help would be greatly appreciated please pm me his contact info and i'll get my husband to give him a ring :)
 
1 - 10 of 10 Posts
Top