Peugeot Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1 (Edited)
Hello!
Bought a 2007 Peugueot 407 sw 2,2l Petrol (ew12 j4) automatic gearbox (4hp20) for about a month ago in fine condition.
It went well except that the starter hesitated at times and did the classic "bad starter-sound" when the teeth collide with the flywheel slightly, but it always started with no problems except for the little noise. At first I thought it was the solenoid that was tired but I was very wrong haha.

Last time the car started it hesitated and "PRND" flashed on the dashboard, and now it became harder and harder to get the starter to even try to go. I pulled the gear lever back and forth, and finally I got in the car running. I drove the car into the garage and turned off.

When I turn the ignition I get a beep and PRND on the instruments and nothing happens when I turn the key to "start".

LEXIA says:
Gearbox: U30F0 - Unknown Code. (Googled and someone on any forum suggests that it has to do with a coil starting relay)
BSI F98B - Engine fusebox front left side light fault
Engine relay unit: F98B
Bootinghousing F98B
And I did not make contact with the ABS / traction control unit (but no error code)

I have checked all the fuses in the car : "Engine fusebox (BSM)" and "BSM" However i havent found no fuse box in the trunk
I bought a used "Engine fuse / relay box BSM on ebay but there was no difference.

When I press the brake with the ignition on it release the gear lever. But when I let the Lexia program to test the feature I could not get it out of position P.

The transmission worked flawlessly and all solinoids and sensors seems to work except the "starting prevention action" which is now active.

Please help me. I starting to get depressed with this strange problem.
I now suspect ground fault and would love to know what F98B stands for ?

Thanks in advance. greetnings from Sweden
 

·
Registered
Joined
·
1,133 Posts
First thing.. have you had your battery load tested to see if it is up to the job? Many faults like yours are caused by a battery which is failing. If not, get it tested and replace if the test shows it is not up to scratch.
Secondly, check all positive and ground connections on the battery and on the starter and to the motor/body of the vehicle. Remove each one, clean, grease lightly with copper-based grease and replace. A lot of faults are due to bad/corroded positive and ground connections. It is worth doing even if it is not the cause of the current problem.
Many faults can be generated by a low voltage/amperage as a result of trying to start. The BSI/ECU loses current and it can spark imaginary faults. Likewise, unplugging items while the battery is connected can also trigger faults which are not actual faults, they simply occur as the system suddenly cant 'talk' to the component and immediately records it as a fault. So checking of any electrical item that involves unplugging it should only be done with the BSI allowed to go to sleep and disconnecting the battery before unplugging any electrical component.

The faults you are currently displaying, have you tried to erase them?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Thanks for the quick reply.
I'll check the battery and its connections more thoroughly tomorrow.
With the multimeter the battery gives about 13V. But I will try to replace it.

The U30F0 code disappears when I delete it and the gearbox says "no error", until the next time I try to start the car, then it comes back.

The F98B is permanent and can not be deleted.

To be continued...
 

·
Registered
Joined
·
1,133 Posts
The multimeter will not tell you the actual condition of the battery when it is put under load. Only a proper load test will do that.

The only reference to the F98B code I can find is to do with faulty side markers, cant find any reference to the U30F0 code so I cant help with the codes being thrown.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
Now i have checked all goundconnections in the enginebay. Replacing all cables from the battery (+and-) I've replaced the battery, with no improvment...
I get the car to start by giving signal to the starter solinoid and the car works perfectly exept from faultmessenges like PRND and "side lamp faults"
This most be a groundfault. Byt i dont know where to look.
Where can i get wiringdiagram and groundpoints information?


Skickat från min SM-G935F via Tapatalk
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6 (Edited)
I keep posting if some one else have/will have this kind of problem.
I've noticed that diagbox program doesn't get in contact with the engine ecu. It doesn't even show up in the list.
-+And I have a connection problem with the ABS EPS -ECU.
-+I don't get any Volts on the left sidelamp ((front), as in the fault code)
-+And I cant quit "economy mode" even in diagbox.
-+Some relays don't seem to work in the engine and in the boot.
-+Can't contact battery charge status unit.
Etc etc...

I've tried to reset the BSI with no luck. I'm starting to think the BSI might be the problem.



Skickat från min SM-G935F via Tapatalk
 

·
Registered
Joined
·
2,476 Posts
Peugeot Wiring Diagrams are in a database called the SEDRE. This is accompanied by the Service Box Documentation, which gives build record, parts information and repair procedures. Get it here.
 

·
Registered
Joined
·
86 Posts
I have the same error F98B on my 2007 307sw and I don't know where to look for this. This is the only thread that I found relating to this fault code.

Mike, could you please give us more details on how you sorted out your problem please?

Thanks!
 
1 - 11 of 11 Posts
Top