Peugeot Forums banner

1 - 20 of 30 Posts

·
Registered
Joined
·
187 Posts
Discussion Starter #1
I just had to be recovered as I went to unlock the car the remote fob didn't work so I used my key and the alarm went off and immobilizer kicked in and won't start . the recovery man had to disconnect my bsi ecu and battery and the siren just to get it to stop . what can cause this . the wipers was going now and then . would this be the bsi failed or what
 

·
Registered
Joined
·
30 Posts
Maybe as simple as resetting the BSI and then re-synching the key fob to the car. Have you tried that yet?

Procedure for Initialising the BSI after key learning
1. Disconnect the diagnostic tool.
2. Put the driver’s window down, lift the bonnet and ensure all
equipment is switched off.
3. Ensure all doors are closed and remove key from the
ignition.
4. Wait for 3 minutes, disconnect the vehicle battery and wait
15 seconds.
5. Reconnect the vehicle battery, wait a further 10 seconds (do
not open doors.)
6. Switch on the side lights through the driver's window.
7. Switch on the ignition and check system’s functionality.
8. Hold lock button on key down for 10 seconds.
9.remove key open & close door test central locking system
10. Start the engine and complete the system’s check.

Also check the battery in the fob, pop a new one in.

Sim
 

·
Registered
Joined
·
187 Posts
Discussion Starter #4
Have done anything to the key or fob (change cover, battery etc)?
no not till it happened . so i thought it was the battery in the fob so I went to shop and changed the battery . at the moment the recovery man has left the ecu and bsi and the battery disconnected and the siren taken out . but he thinks the bsi has lost all the information
 

·
Registered
Joined
·
187 Posts
Discussion Starter #5
Maybe as simple as resetting the BSI and then re-synching the key fob to the car. Have you tried that yet?

Procedure for Initialising the BSI after key learning
1. Disconnect the diagnostic tool.
2. Put the driver’s window down, lift the bonnet and ensure all
equipment is switched off.
3. Ensure all doors are closed and remove key from the
ignition.
4. Wait for 3 minutes, disconnect the vehicle battery and wait
15 seconds.
5. Reconnect the vehicle battery, wait a further 10 seconds (do
not open doors.)
6. Switch on the side lights through the driver's window.
7. Switch on the ignition and check system’s functionality.
8. Hold lock button on key down for 10 seconds.
9.remove key open & close door test central locking system
10. Start the engine and complete the system’s check.

Also check the battery in the fob, pop a new one in.

Sim
i tried but with the alarm going off as soon as the battery is connected the bsi wont shut down
 

·
Registered
Joined
·
1,805 Posts
What engine is it?

Siemens injection systems have reputation of losing BSI info if the battery goes flat, runs low or is in poor condition.

Putting the car on PP (with everything plugged in!) should tell you whètherbtge BSI has retained the info - if PP doesn't read the VIN, you'll need to set the BSI parameters
 

·
Registered
Joined
·
187 Posts
Discussion Starter #7
What engine is it?

Siemens injection systems have reputation of losing BSI info if the battery goes flat, runs low or is in poor condition.

Putting the car on PP (with everything plugged in!) should tell you whètherbtge BSI has retained the info - if PP doesn't read the VIN, you'll need to set the BSI parameters
I only changed the battery in the car 8 months ago . it the 2.0 110 hdi on a 52 plate
.I know the bsi is a valeo
its says on service box injection associated variant mounting bosch
do I need the pass card that comes with the car for setting the bsi ?
 

·
Registered
Joined
·
187 Posts
Discussion Starter #9
Yes, it's a Bosch, so you should be ok.

Check whether the key is coded on PP2000,
I will have too wait till every one gone to work Monday . because alarm goes off. but why wouldn't the remote fob work ?. does the transponder pick the signal for that up when trying to unlocking it
 

·
Registered
Joined
·
93 Posts
When you changed the battary did you do a full bsi reset and try the locking of the doors?

Sounds like your key needs re progrsmming to the car....
 

·
Registered
Joined
·
187 Posts
Discussion Starter #11
When you changed the battary did you do a full bsi reset and try the locking of the doors?

Sounds like your key needs re progrsmming to the car....
yes the car been fine up to today . its has if it doesn't recognizes the key or remote
 

·
Registered
Joined
·
187 Posts
Discussion Starter #12
right I have sorted the alarm and immobilizer out and can start the car and drive . it was the steering comms 2000 unit failed . changed it with a old one the that's sorted . but now I can't open the boot . when I unlock the car all the doors unlock part from the boot the rear wiper goes every time I unlock the car . its if the power is going to the wiper instead . i asked Peugeot if the comms unit would cause this and they said no the bsi controls the locking .but if that's right why just the boot surly all doors are on the same bit to open with remote . but i could unlock all the car with the key when the the alarm went off as i needed my tools . this is only since i changed the comms . i have tested with planet and no faults on the bsi . plus one new one about no+ve on the multifunction display and the only other faults where the ones i had before glow plug and air con . . any advice welcomed
 

·
Registered
Joined
·
187 Posts
Discussion Starter #14 (Edited)
Have you checked the locking settings on Planet?
no ?
can you explain a bit more ?
I have gone in and checked the passengers and drivers door modules and they are ok .but it doesn't let you check the boot .
I have even taken the micro switch off the boot and put a live to the wire to see if that open it and nothing . but opens if I touch the live to the grey on the mechanism
 

·
Registered
Joined
·
187 Posts
Discussion Starter #15
I have noticed when the bsi goes to sleep ( 3 minutes) and i open any door the rear wiper goes . Just the same if i go to use the remote on the key . But still no boot opening

Sent from my Hudl HT7S3 using Tapatalk
 

·
Registered
Joined
·
93 Posts
The pp2000 has a option to cheek all the locks roof and everthink and gives you a report .

The po2000 will open and clse boot lock , that how it tested ...

Can you open the bot via pressing the bot button on the back .....
 

·
Registered
Joined
·
187 Posts
Discussion Starter #17
The pp2000 has a option to cheek all the locks roof and everthink and gives you a report .

The po2000 will open and clse boot lock , that how it tested ...

Can you open the bot via pressing the bot button on the back .....
no I can here the micro switch clicking . I have checked the door modules and no faults but there is nothing for the boot under locking and unlocking
 

·
Registered
Joined
·
187 Posts
Discussion Starter #19
No the micro switch works . I Have even put a live to the switch wire and nothing . The only way to open is dropping the back seats . It still doesn't explain why my rear wiper goes when i remote unlock the drivers door or leaving the door shut after the car has been unlocked and then i open it

Sent from my Hudl HT7S3 using Tapatalk
 

·
Registered
Joined
·
187 Posts
Discussion Starter #20
what controls the locking and unlocking the boot . the lock works fine . if I run a live feed to the grey wire it unlocks . but if I run the live feed from the micro switch handle connector theirs nothing . plus my rear wipe keeps going every time I unlock the car . I had trouble with the alarm going off and the remote key not working and not starting . so Peugeot said the comms controls that so I changed that and now it will start and no alarm but the I still have this issue. can anyone tell me . Peugeot said the bsi does the locking of doors

Sent from my Hudl HT7S3 using Tapatalk
 
1 - 20 of 30 Posts
Top