Peugeot Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
63 Posts
Discussion Starter #1
Hi guys
Problem with my 307 1.6 51 reg hatchback.
The problem is stalling whilst hot I'll try explain.
Stopped at traffic lights yesterday temp goes to about 90 just before fan kicks in lights change I lift clutch to set off stalls ( not my fault) car took about 10 seconds to restart same again stalls eventually get it past lights as it eventually moved but was very sluggish and was no power then something kicked in and full power.
So managed to get it home
Car ideling on drive temp gets above 90 -95 fan kicks in temp drops back down fan goes off tried this for 5 times on drive letting fan kick in all OK car did not stall.
So goes out to test it today on drive all OK ideling so thought I would go out to test drive lift clutch to go for a test drive reversed bout of drive and it was fine untillbi went forward then stall
This is only happening when its hot
Any ideas
 

·
Registered
Joined
·
63 Posts
Discussion Starter #2
Quick update
whilst posting on here about the problem the car was ideling on my drive once i posted the original problem the car had stopped so is also doing this whilst ideling
any ideas guys seems only whilst over 90deg
 

·
Registered
Joined
·
599 Posts
IIRC you should have a two speed fan.
The first speed cannot be heard, the second one is full blast.

Take a look at the front of the car while idling, at around 85 or 90, is the fan on the first speed?
 

·
Registered
Joined
·
63 Posts
Discussion Starter #4
IIRC you should have a two speed fan.
The first speed cannot be heard, the second one is full blast.

Take a look at the front of the car while idling, at around 85 or 90, is the fan on the first speed?
This is a petrol not diesel is it still a 2 fan speed?
 

·
Registered
Joined
·
14,650 Posts
I would think something is getting too hot and confusing the ecu doubt the cooling fan is anything to do with it as its not actually overheating just hot.

It may be a wiring issue or possibly the heat affecting the coil pack.
 

·
Registered
Joined
·
63 Posts
Discussion Starter #7
i noticed when the car got to around 90 deg the engine seemed to drop not a lot only a little then pick up again?
 

·
Registered
Joined
·
599 Posts
I bet it has dual speed cooling fan, and the slow speed fuse and/or relay is kaput.

IIRC, the relay is near the fan itself, not easy to get to.

Get someone with PP2K to diagnose it for you...
 

·
Registered
Joined
·
63 Posts
Discussion Starter #10
I bet it has dual speed cooling fan, and the slow speed fuse and/or relay is kaput.

IIRC, the relay is near the fan itself, not easy to get to.

Get someone with PP2K to diagnose it for you...
thanks

i already have pp2000 but not sure how to look for the fault?
thanks
 

·
Registered
Joined
·
599 Posts
Find a way, to test the fan. Someone here with more experience than me will chime.

PP2K let's you test almost every device, gauge etc, to see if they can work.
 
1 - 11 of 11 Posts
Top