Peugeot Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
A month ago I was driving when EML came on then Antipollution fault came up. It's in limp mode at the moment after reading the forums I thought it was the DPF as the fluid tank under the car was empty. So I took it to a garage to have it removed and the ECU remapped to take the fault out of the system. They called me a few hours later saying the DPF has already been removed by previous owner but they can't remap the ECU because the computer is not communicating with the ECU. They said it's probably the wiring from the connector to the ECU as the car still runs. Anyone had this problem and what sort of cost to get fixed ????
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Sorry didn't notice the rules. I'm in north wales and the place I took it to is a well known tuner. It wasn't a problem reading codes the problem is no communication between the port and ECU
 

·
Moderator
Joined
·
11,780 Posts
Item 8 - Get it checked with Planet / Diagbox to confirm if there's a connection.

I don't do North Wales diags any more as there's someone closer.
 

·
Moderator
Joined
·
5,884 Posts
A decent mapper should have access to BDM and should be able to read/mod engine ECU with it removed from car so no need to rely on OBDC.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #6
The company I went with was zaviz international. They know what they are doing. Just an update its booked in next week with an auto electrician will keep you posted and thanks for the comments
 
1 - 6 of 6 Posts
Top