Peugeot Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hi new to this so 'be gentle'-changed cranshaft sensor and it wont start , replaced old one and wont start ?
I need this puppy back on the road TODAY !!!
IDEAS PLEASE
 

·
Registered
Joined
·
6 Posts
Discussion Starter #4
Cut out last night -AA did diagnostic which said crankshaft sensor fail, was dripping in dirty oil so he cleaned it and i drove home 40ml fine -he did say worth changing incase intermitent fault -so i did and now it wont restart
 

·
Moderator
Joined
·
6,081 Posts
Did you get the correct sensor, if it was the wrong one it may have logged a fault which is stopping it starting
 

·
Registered
Joined
·
6 Posts
Discussion Starter #7
Local parts shop gave me part according to reg so im presuming so
Diagnostics from a mate not showing any codes
 

·
Registered
Joined
·
15,096 Posts
2 things

1 sensor may not have been the fault WIRING is far more likely and you have now broken the circuit
2 diagnostics needs LIVE DATA codes dont help here live data and lots of it

In live data you need to see an engine speed signal if it is not showing anything while cranking or it is less than 250 rpm engine wont fire

Not disconnecting battery is fine it is more likely to cause issues if you DO disconnect due to 3 minute rule etc
 

·
Registered
Joined
·
15,096 Posts
Ok at least you have something check for cam and crank sync now

Is the rev signal pulsing up and down if so the sensor ring may be damaged or the sensor is not flat against the engine properly
 
1 - 12 of 12 Posts
Top