Peugeot Forums banner

1 - 16 of 16 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
i have a 307 2.0 hdi 51 plate that wont start i had a few problems in the winter when it was cold and had a few problems when using it at night it woulnd start in the morning. i had battery check 51% dead and alternator check all ok so carried on using it jump starting it when it woulnd start and it run fine untill one day she cut while driving at 70 and woulndt restart got tow home bumping on the way and it ran for a min or so and stopped left in on drive for a few hours and she started (with a jump) and ran fine.

i thought the battery wasnt taking a charge (but alternator is working well) so i bought anew battery and fitted today and she start ran for a min the stopped and now wont restart.

does anybody have any ideas please.
 

·
Moderator
Joined
·
5,879 Posts
When was fuel filter last changed? 110 or 90 bhp

if 90 pump primer to see if air leak/lock etc

if 110 i would check in tank fuel pump is working or its filter is blocked. of give it a clout first as they can stick you should also be able to hear pump run when ign is switched on (some people say they see the fuel filter swell when pump runs)

Unless you are using surge protected jump leads take care as very easy to spike BSI/engine ECU's etc on most PSA cars when jump starting
 

·
Registered
Joined
·
17 Posts
Discussion Starter #3
thanks fuel filter done 6 months ago had a few problems with it before (i am see air in clear pipe from filter to pump on engine (have been told thats ok???))

its a 90 and the priming bubble is solid?
 

·
Moderator
Joined
·
5,879 Posts
Have only worked on one 2.0 90 hp and on that bulb never goes hard fuel just cycles back to tank, there should be no air in fuel line from filter to pump as the lift pump is intergrated into HP pump and it wil not self prime/operate with air in the feed lines.

I would check all fuel lines (maybe disconnect tank return and see if primer then lifts fuel and pumps out of return line
 

·
Registered
Joined
·
3,426 Posts
there is never a constant flow of diesel from the filter to the engine on my 2.0 90bhp.

i gather you mean there should be non from the tank to the filter
 

·
Registered
Joined
·
17 Posts
Discussion Starter #11
I reset the bsi ( i think I did it followed instructions) and to my surprise it started and run well but when I reved I see air lots of it in the clear pipe between filter and pump then she cut out and won't restart

So I assume I have a leak sucking in air

The question is where do I start
 

·
Registered
Joined
·
17 Posts
Discussion Starter #16
Yeah plenty of fuel in tank cant find any air leaks but I suspecting pump as she now wont run start or anything can't even prime system

I have disconnected pipe from pump to fuel rail and when I turn over engine I get no fuel

Any ideas welcomed
 
1 - 16 of 16 Posts
Top