Peugeot Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1 (Edited)
hi all,had a burst water hose,repaced the hose,now no hot air tried bleeding the two bleed screws, to no joy,he car does not lose water,i think it is a circulation problems any help would be welcome, it is an 03 2.0 ltr hdi thank you
 
S

·
Guest
Joined
·
0 Posts
Did it burst due to freezing?

If so it may have knackered the thermostat when it froze, so it will be stuck open

Just an idea!
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
thanks, yeah it did,changed the thermostat,it is if it air locked,it heats up when driving but starts to cool down when ticking over,
 
D

·
Guest
Joined
·
0 Posts
Fit a bottle to the top of the coolant reservoir and bleed it again. You need a good 'head' of coolant to bleed correctly.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #5
thankyou,will try that today,let you know how i get on,do i bleed it when hot or cold , mark thanks
 

·
Registered
Joined
·
7 Posts
Discussion Starter #6
tried bleeding it that way,heater still not going hot,realy puzzled,looks like a garage,hate paying there prices,many thanks for your help
 
D

·
Guest
Joined
·
0 Posts
The waterpump impellor may be broken off and no circulation. That engine needs serious looking at.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #8
thanks davidireland,that sounds as if it is the problem,yhe bottom of the radiator is not heating up,if its going to break,break it right,thanks again. [thanks for the bad news] lol let you know how i get on mark
 
1 - 8 of 8 Posts
Top