Peugeot Forums banner

1 - 19 of 19 Posts

·
Registered
Joined
·
3,426 Posts
Discussion Starter #1
hi all. does anyone know if the buttons on the heater control panel should light up?

on the back of the unit there is 3 bulbs. i tried swapping bulbs round but cant see to get them to light up.

its pretty difficult setting the heater with all the dark roads around here

its the one with the display if that helps

im hoping i can get this sorted before my sprayed centre console has dryed ready to go back in.

many thanks lee
 
J

·
Guest
Joined
·
0 Posts
Yes, should be lit up... if the bulbs are there but not working, then maybe they've blown? If they are like the ones on my old 306, they're only a quid or so to replace so may be worth a try.
 

·
Registered
Joined
·
3,426 Posts
Discussion Starter #3
thanks. the cars in bits at the moment. when i swapped working bulbs round they still didnt seem to work. i even managed to break a fuse

im having an issue with electrics latelly so i will try to sort it
 

·
Registered
Joined
·
437 Posts
I'm so glad I found this thread. I was just about to ask the same question.

Good luck Monty. I'll be having a go at this now too.
 

·
Registered
Joined
·
3,426 Posts
Discussion Starter #5
i have received the bulbs this morning.

i will wait until its dark and fit them to see if they work.

the middle bulbs for the display work just not the buttons. i have a few days before it goes back together so will try and sort it if not ill source a new display

french electrics eh :)
 

·
Registered
Joined
·
437 Posts
i have received the bulbs this morning.

i will wait until its dark and fit them to see if they work.

the middle bulbs for the display work just not the buttons. i have a few days before it goes back together so will try and sort it if not ill source a new display

french electrics eh :)
French electrics indeed.

I've just sorted my heater control panel. Turned out it's just one bulb supplying light to all the buttons, changed it and it's sorted. :)

Don't know why I didn't do it sooner.
 

·
Registered
Joined
·
3,426 Posts
Discussion Starter #7
i only asked cause my missus dad was in the car and he asked why they werent lit up.
i didnt even realise even though i was always messing about in the dark trying to work out what button was what
 

·
Registered
Joined
·
3,426 Posts
Discussion Starter #8
i have fitted a new bulb

the one i have fitted is the only one that seems to work

i tryed to change the other 2 and it sparked and now no lights on the speedo will work.

i turned the car off and the lights. any ideas what fuse is needed. even the mileage doesnt work or the rev counter
 

·
Registered
Joined
·
3,426 Posts
Discussion Starter #10
its a 2001 51 plate. i have tried following the haynes manual but no luck

all lights work. the bsi just doesnt wake no speedo lights no mileage etc everything else is working
 
J

·
Guest
Joined
·
0 Posts
Does the radio work?

Looking up the fuses in the handbook, it lists fuse no.24 (15 amp) as being for the Instrument panel - Audio equipment - Multi-function display - Air conditioning.

It also lists the radio under fuse no.11 (15 amp) so may not identify it properly, but I'd definitely be looking at fuse no.24 :nod:
 

·
Registered
Joined
·
3,426 Posts
Discussion Starter #12
thank you so much. it was f24

how do i change a bulb without sparking it again?

i have fitted 2 new bulbs but one still not working

super weird as only 1 was blown out of 3 before seems weird the other 2 have died
 
J

·
Guest
Joined
·
0 Posts
Remove that fuse before removing/fitting the bulbs... won't be any power in the circuit then to be able to fuse it again :thumb:
 

·
Registered
Joined
·
3,426 Posts
Discussion Starter #14
is that safe seeing though it seems to affect the bsi in some way.

i turned everything off to make sure this didnt happen lol
 
J

·
Guest
Joined
·
0 Posts
How is it affecting the BSI??

If everything was turned off, there wouldn't have been 12v there, and so wouldn't have fused... there must have been some power there somewhere. Did you just use your fingers to fit them, or pliers?
 

·
Registered
Joined
·
3,426 Posts
Discussion Starter #16
the bsi wasnt waking with that fuse blown.

i took the fuse out took the 2 old bulbs out cleaned the contacts up as i noticed even when inserted the bulbs were rocking a little in the holder whereas the new ones weren't.
I now i have 3 working bulbs :)

i used pliers which doesn't help. i couldn't see a way of doing it otherwise the bulbs are pretty fiddly
 
J

·
Guest
Joined
·
0 Posts
Using pliers can explain why you blew the fuse :lol:

How do you know the BSI wasn't waking up?
 

·
Registered
Joined
·
119 Posts
Sorry to change the topic slightly - do you know what bulbs are used behind the heater controls (manual, non-climate control) of the 02 307? Is it the same as the license plate bulbs?
 
1 - 19 of 19 Posts
Top