Peugeot Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
90 Posts
Discussion Starter #1 (Edited)
Hi all, i still cant get to the bottom of my hdi90 and how poor it drives before boost. It seems worse when its very cold.

PP2000 not throwing up anything at all and the MAF airflow readings seem correct.

The only thing i have noticed is an odd fuel temp reading, sometimes at 90 degrees. I have a replacement fuel temp sensor in the post.

The vacuum hose is removed for the EGR, should i reconnect it?

I have just changed the oil, air filter, oil filter however i did miss the fuel filter but really cannot see how this would affect this small range in the revs.

Its doing my head in and makes the car very difficult to drive smoothly!
 

·
Registered
Joined
·
4,778 Posts
Hi all, i still cant get to the bottom of my hdi90 and how poor it drives before boost. It seems worse when its very cold.

PP2000 not throwing up anything at all and the MAF airflow readings seem correct.

The only thing i have noticed is an odd fuel temp reading, sometimes at 90 degrees. I have a replacement fuel temp sensor in the post.

The vacuum hose is removed for the EGR, should i reconnect it?

I have just changed the oil, air filter, oil filter however i did miss the fuel filter but really cannot see how this would affect this small range in the revs.

Its doing my head in and makes the car very difficult to drive smoothly!
try run it with the maf disconnected and see if it runs better if it does then its the maf
 
1 - 2 of 2 Posts
Top