Peugeot Forums banner

1 - 16 of 16 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Hi all just signed up your help needed please just got a 307 hdi 110 on the motorway the other day put my foot down on throttle nothing there took my foot off put down again and it picked up and went well but it does this on lower speed too what could this be please?
 
C

·
Guest
Joined
·
0 Posts
Scott How is your MPG? I lost a lot of my engines power and my MPG Nosedived when my MAF went down cost me about £40 from ECP 2 mions to fit and all sorted. Also don't forget that clogged & Dirty air / fuel filters will rob your engine of power along with certain fuel my 407 does not like Morrisons Diesel one bit.
 

·
Moderator
Joined
·
11,711 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #5
Hi its been serviced recently and I unpluged the maf and tried it, it was flat on power it was dead really should that be right?
 

·
Registered
Joined
·
1,045 Posts
no you should have some power if you unplugged the maf sensor if you had gotton some power back then it would be your maf sensor,

so my money is on the turbo sensor is duff you could swap this with your egr one and road test it but make sure you remember what pipe
goes were vac goes to the vacume pump , out goes to your turbo or egr :thumb:
 

·
Registered
Joined
·
9 Posts
Discussion Starter #7
Thanks cmax my mate has just been round and plug his computer in and it says turbo boost where will the boost be is it on the turbo its self?
 

·
Registered
Joined
·
1,045 Posts
no its not the on the turbo theres a solenoid on the front of the engine beside the oil filter yours has 4 of them the one with the light gray plug is the turbo one you can swap this over with the blue plug solenoid thats the one that works the EGR,

how the solenoid works is it draws vacume from the vac pump and when the ecu tells the car to boost the solenoid opens so the vacump closes the wastgate to make the car boost :thumb:


if you swap the two over and it works then you need a new boost solenoid

i will post up the part number if you need it as its cheaper if you get one from another model plus its the never verson thats been made to last
 

·
Registered
Joined
·
21 Posts
no its not the on the turbo theres a solenoid on the front of the engine beside the oil filter yours has 4 of them the one with the light gray plug is the turbo one you can swap this over with the blue plug solenoid thats the one that works the EGR,

how the solenoid works is it draws vacume from the vac pump and when the ecu tells the car to boost the solenoid opens so the vacump closes the wastgate to make the car boost :thumb:


if you swap the two over and it works then you need a new boost solenoid

i will post up the part number if you need it as its cheaper if you get one from another model plus its the never verson thats been made to last
i had this problem and after a few days it went into limp mode, it cost me £1 for a new plug, a bit of tape and 2x connectors :)
 

·
Registered
Joined
·
9 Posts
Discussion Starter #13
Hi all where by is the sensor there are 2 grey plugs one sensor is under the oil filter and the other one is to the right of the oil filter?
 

·
Registered
Joined
·
1,045 Posts
strange that you have two gray ones, as you should only have one but easy to check if you get under the car you will see a vac pipe from the turbo one going under the car along the sump and thats your turbo one :thumb:
 

·
Registered
Joined
·
9 Posts
Discussion Starter #15
Hi all where by is the sensor there are 2 grey plugs one sensor is under the oil filter and the other one is to the right of the oil filter?
 
1 - 16 of 16 Posts
Top