Peugeot Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi. Just picked up my year old e-208 and I’m struggling with the MyPeugeot app. First it wouldn’t send a confirmation email, so had to start again using my work one.
Now, my iphone has connected (at least it’s showing connected on by Bluetooth screen), but the app is not showing any charge or range info, nor does it allow any temperature or charge control.
At the top of the page, it says ‘the subscription is in process’…any ideas?

Tire Automotive parking light Wheel Hood Automotive lighting
 

·
Registered
Joined
·
1 Posts
It takes some time for e-remote subscription to activate. It should be available in few hours. That was my experience with the app last week. :)
 

·
Registered
Joined
·
9 Posts
Also, the app is a bit rubbish. Every other day mine is in French, I've never chosen that language. Plenty of times it refuses to update the charge info and remaining range. The location regularly shows me to be in Bristol, for some unknown reason, I live in the Highlands and haven't been to Bristol in 25 years.
Your mileage may vary. 🙈
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #4 ·
Looks like it’s slowly getting there. I’m now being prompted to do the ‘several 20 minute journeys’.
Its all a bit crap…a friend has just bought a Kia Niro, and he was straight onto their app with no bother!
 

·
Registered
Joined
·
102 Posts
What is it that takes time? If Peugeot wanted it, starting a subscriptions could be done in seconds. Or do they hire people that sit by old fax machines where a request for a subscription is printed out, then send these papers on by snail mail to some other city, then someone open the letters and enter it to a computer.
 
1 - 5 of 5 Posts
Top