Peugeot Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
12 Posts
Parking sensors

I live in Amsterdam and have just paid a Peugoet dealer €495 to fit parking sensors to my 2016 208. They work beautifully the only thing that is strange is that the display screen goes blank when I engage reverse gear. My partner has a UK 2014 model 2008 and she sees a car symbol with icons that show which sensor is alerting. I am wondering if I need a software update or if they missed something.
 

·
Registered
Joined
·
12 Posts
Reversing sensors

Thanks for the reply. I was thinking of going to another daeler to ask as I think it may be due to the version of SMEG. I also have an Axiom Satnav that is only accessible after holding down the steering-wheel/radio button for two seconds.
 

Attachments

·
Moderator
Joined
·
6,473 Posts
The retrofit pdc aftermarket system fitted by most dealers is not the same as the factory fit on most models. It's a standalone PSA approved system which uses different sensors and control unit which does not communicate with MFD unit CAN system so you get no display on MFD just audible alerts.

You can retrofit original sensors harness and ecu and program with diagbox to get full function

Sent from my SM-T310 using Tapatalk
 

·
Registered
Joined
·
12 Posts
Reversing sensors

Interesting? Thanks for you reply.

The dealers, like almost all businesses, here in NL, treat customer service like some kind of game and seem to love giving you as little info as possible. Having no display is not a massive problem it's just strange that the display goes black when you engage reverse, so I would have thought there must be some connection? I also wondered if my screen needed an update.
 

·
Moderator
Joined
·
6,473 Posts
It has possibly it had the parking sensor option enabled in the BSI to power the system when reverse is selected which also switches display but due to lack of CAN data screen just goes blank

Sent from my SM-G935F using Tapatalk
 
1 - 7 of 7 Posts
Top