Peugeot Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
Hi I have a 307sw 2004 automatic, inicially the gear box fault sign appeared, the gear box didnt make any change, the display didnt show N, P D on the cluster but instead (-), took it to the dealer, they said the gear box didnt have coneccion with the computer, they reseted it and the problem desapeared, 100 kilometer after the same fault appeared but this time with more fault codes, ABS, instrument cluster stoped working and a "STOP" sing blinked all the time. I stoped the car but after it didn´t start anymore, I disconected the battery for an hour and tried igan and worked perfectly for about 40 kilometres, next day appered again with the same problems, the dealer told me I need a new computer, what do you think will it solve the problem. By the record this problem appeared after installing a new radio (Becker Traffic Pro 7949) but dealer said it didnt have a link with the problem.... Thanks
 

·
Registered
Joined
·
41 Posts
You must connect the car to diagnostic computer to know

if any error code will be appeared and to verify if the ECU is communicate well...Good Luck
 

·
Registered
Joined
·
14,553 Posts
Radio actually could be your real issue as the whole car including the radio is networked and the aftermarket radios wiring may be shorting the network wiring leading to all the errors !!!
 

·
Registered
Joined
·
15 Posts
Discussion Starter #4
Problem solved, at the dealer they checked the harness, didn´t find any trouble, took out the automatic gearbox module and took half glass of water out if it, replaced the module and it´s working fine. Seams the module sealing didn´t work well....i parked the car outside resently with an inclination on the side from the floor, driver side down, and water purded continusly when it rained towards the battery and module....i covered the new module to avoid it to happen again.
 
1 - 5 of 5 Posts
Top