Peugeot Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter #1 (Edited)
Had a couple of starts where the engine starts rough and can't touch the accelerator cause engine wants to cut out then. Had my bluetooth OBD with Torque on my phone in the car and checked the fuel pressure which was 179psi. After a minute or two it suddenly ran fine again and checked the pressure again and had around 700psi! Could add that usually when ignition on you can hear the pump a couple of seconds bulding up the pressure but today it was on for at least ten seconds before it stopped and I turned the engine on.

I suppose the fuelpump is on it's way to give up or could it be something else?

If you also sya it's the pump, where can I buy one for a reasonable price? I expect Peugeot here in Sweden to have a juicy pricetag.


Edit 1: I just found out there are two fuelpumps, one in the tank and one high pressure on the engine! How do I find out which one is faulty?

Edit 2: Can diagbox show the pressure of both pumps?
 

·
Registered
Joined
·
45 Posts
Discussion Starter #2
Had Diagbox connected to the car and started, went to fault finding and found a menu where I could see fuel pressure. It showed 5 bar with ignition on. Started the car which ran very rough and fuel pressure was only around 17 bar. EML came on with P1336,1337,1338 and 1340. Turned engine off and restarted, fuelpressure went up to 48 bar and engine ran fine again.

I am guessing it's the high pressure pump, any tips on where to get one at a good price?

Cheers!
 

·
Registered
Joined
·
45 Posts
Discussion Starter #6
Replaced the pump yesterday and car is running fine again! Bought the cooper N14 pump at the BMW dealer and got it for less then half the price!! Shame on peugeot to charge that kind of money for the same thing!

Thanks guy's!:)
 
1 - 6 of 6 Posts
Top