Peugeot Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi all.

Issue with front drivers side window on peugeot expert 2009 (2.0hdi)

with just the ignition on i can hear a click from the motor so i know its getting power.
Its the same click i get from the other side when its either fully down or fully up and you try to move it a bit more, just a single click because it doesnt need to move anymore.

window is currently up. over the past months, every now and again it would stop working and then for some reason right itself. well it hasnt done that for a while now and its hot and i like the window down. Any answers or suggestions....

unplugging and plugging wires has been done, a gentle tap of persuasion has been tried on the motor but nothing

Please help if you can as to what i could do or need to replace.
many thanks
 

·
Registered
Joined
·
6 Posts
Have you tried cleaning the contacts in the window switch? Ours is prone for getting dust inside. The panel pops out of the door, disconnect the harness, then you can carefully pull the plastic latches out to open the unit. It uses those little carbon pads same as you get in remote controls. I clean all the contact points and the pads with a bit of electrical contact cleaner and it works fine again.

Failing that, open the door up and see what's happening with the motor. Put a meter across it and see if it gets power when the switch gives demand, up or down. See if there is an open circuit across the motor coil indicating a burnt out coil. If I remember correctly this motor relies on a torque switch for it's limit travel so make sure the body can still rotate in the housing to activate the switch if you can get at that (I've not looked at ours in a long time so may be talking rubbish there). If you are confident disconnecting and reconnecting the cable system, disconnect it and make sure the window itself is free to travel up and down.

Hope that helps for starters for things to consider
 
1 - 2 of 2 Posts
Top