Peugeot Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
48 Posts
Discussion Starter #1
Recently the wipers had a mind of their own, where they started on their own and could not be turned off, only by disconnecting the battery.

Although this has not re-ocurred since, but now the Central locking will not lock the front L/H or R/H doors. The rear doors and tailgate are OK.

When remote locking I can hear a buzzing sound not sure whether its from the front or rear.

If I lock the drivers door by key and the unlock with the remote. The door stays locked.

Done a Peugeot BSI reset with no results.

Main problem I cannot lock the front L/H door manually till I solve the central locking.

Any tips of what to check first with the Central locking.

Thanks
 
D

·
Guest
Joined
·
0 Posts
Check for water in the BSI. Check for broken wires in the rubber boot between the doors and the chassis.
 

·
Registered
Joined
·
48 Posts
Discussion Starter #3
Thanks

When I say I did a Peugeot BSI reset, I followed the instructions as per:- Peugeot BSi reboot procedure


Ok , where would I find the BSI to check for water.

As for broken wires in door connection, its strange that both door wiring should fail at the same time. I could understand if is was days/weeks apart when the locks failed. But i will check them.

Thanks again
 

·
Registered
Joined
·
48 Posts
Discussion Starter #4 (Edited)
OK,

I've read that water ingress onto the BSI could be from a faulty Bonnet release cable grommet in the bulkhead or the small blank grommet alongside, both seem to be good (tight fit in bulkhead and cable).

So to check the BSI connections etc, how do you remove the various plugs (release them).

I cant remove them, any tips of how to. Also is there anywhere else water could get in as there is some water under the matting and the sponge material is wet on the floor and bulkhead. But its clear water (Rain water) not coolant as I'm not loosing any.

thanks
 

·
Registered
Joined
·
48 Posts
Discussion Starter #5
OK

Whats next ??

I've taken out the BSI assembly and cleaned all the pins etc with an electronic PCB cleaner and cannot see any signs anywhere of water ingress/algae//corrosion etc. to the assembly.

Refitted the board and carried out the Re-boot procedure for the BSI, several times and Its still the same.

The remote locks and unlocks the rear doors and tailgate only, but if using the key in the drivers lock. This will lock and unlock everything but the front passenger door.

I have a Fluke enginneers meter. What and where can I check for the fault in a proccess of elimination.

As said earlier, this problem with front locks started when the wipers went barmy on thier own and could only be stopped by disconnecting the battery. If only one lock didnot lock/unlock, I would check that motor and circuit etc. But for both at the same time, I think its alittle more.

Thanks
 
1 - 6 of 6 Posts
Top