Peugeot Forums banner
1 - 12 of 12 Posts

·
Registered
Joined
·
326 Posts
Give us a clue why do you think it needs replacing? In fact the ECU rarely fails. Much more likely to be something else and if needed you can send it off for test/ repair
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #8 ·
Give us a clue why do you think it needs replacing? In fact the ECU rarely fails. Much more likely to be something else and if needed you can send it off for test/ repair
I have looked and checked most of the sensors, I noticed a build up of leaves in the area of the eco, plus it was wet, probably been wet for ages as it is parked under a sycamore tree with leaves etch getting washed down, building up around the eco, I cleaned all around and dried it off as best I could, left it to completely dry away from tree.
Turn it on engine light stayed off! Drove it around all ok, next day after heavy rain I was driving around and it came on. managed to get it back ok, although power was lost occasionally but then it surged forward?
 

·
Registered
Joined
·
326 Posts
It’s not the ECU…. Don’t waste your time on that. They are fully weather sealed.
What are the diagnostic codes?
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #10 ·
Ill have to find that out need a gadget!!
It is more where all the wires are at the bottom where all the dampness and leaves were, once they were cleared and dry it was ok
John
 

·
Registered
Joined
·
326 Posts
Well dry the plugs out. Give them a good spray of wd40 and put them back. Keeping them dry.

do not replace the ECU without proper diagnosis
 
1 - 12 of 12 Posts
Top