Peugeot Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
96 Posts
Discussion Starter #1
Hi

Usually only in the winter mostly when I have the radio on the signal is always fine with no issues at all. But then if i demist the rear window as well the signal starts going crackling. As soon as demist is turned back off it's all fine again.

Does anyone know the cause and how to fix it?
I know the aerial is in the back window of the 407? Or so I was told.

Any help would be great. Not a big issue at all just bugging me.
 

·
Registered
Joined
·
815 Posts
It will be interference.... the antennae for the radio is actually printed on to the rear screen or shares the same lines. Does the reception clear up as the mist evaporates?

I doubt it's a common fault as many others would be complaining. It'll most likely be an issue you got to live with. Maybe what you can do is clean the rear screen with a good glass cleaner. Failing that, it might be the aerial diversity box or rear windscreen glass itself. It could be a poor ground somewhere in the rear too.
 

·
Registered
Joined
·
96 Posts
Discussion Starter #3
Makes sense it could be the mist as in the summer you rarely notice it and only noticing it now because of the cold and warmth since the weather cant decide what to do. All the mist has to be gone then no interference. But the heating turns itself off after a set time.
I did think a bad earth as well.
Will clean the window as I think that's the only one I didnt do because you have to get up on the seats etc.
I have good cleaning products so no issues with what I use.

Might just live with it if it Carrys on and wait til summer lol

Thanks.
 

·
Registered
Joined
·
108 Posts
Does every heater work when you are demisting the windshield?
If not, the problem is in the electromagnetic field because the signal from the heaters interferes antenna signals, happened to me after removing tint from windows, I broke 2 heaters, and from then the problem started, right after hitting windshield heater, radio jams all the stations and can't find any, after I turn it off everything is working just fine. :)
Hope I helped you somehow.
 

·
Registered
Joined
·
96 Posts
Discussion Starter #5
I will check. I know you can buy pens or soemthing that help join the lines back up so will check that next time it mists up.

Process of elimination I like it.
Thanks
 
1 - 5 of 5 Posts
Top